How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask tristan Your Own Question
tristan
tristan, ASE MASTER
Category: GM
Satisfied Customers: 1608
Experience:  8yrs. exp. ASE MASTER
10186415
Type Your GM Question Here...
tristan is online now
A new question is answered every 9 seconds

2015 lml duramax will not start after replacing the CP4, FRP

Customer Question

2015 lml duramax will not start after replacing the CP4, FRP sensor, and the FPRV . installed a fuel pump at the filter, providing 4 to 6 PSI to the CP4 and still no start. Also it will pressure up at the pump and will hold pressure.
Submitted: 8 months ago.
Category: GM
Expert:  tristan replied 8 months ago.

How much pressure in psi do you have after cranking for 12 seconds?

Customer: replied 8 months ago.
I don't know for sure, as i don't have a guage to check it with. Are you thinking it has a injector leaking off. There is no white smoke coming out the exaust when I Do get it running with a short shot of starting fluid. ( the heater grid wire is unhooked ) Of course, it would be hard to tell with all the emissions hardware still in tact. It idles nice and smooth, with no miss when it is running. It can also be driven with no issues when its running. Turn it off and immediatly try to start it ,and it just cranks. Also it cranks over well , not slow ( normal ).
Expert:  tristan replied 8 months ago.

I've never seen this. Honestly for me to help you need a acantool that view data and check codes because if all it need is a shot of starting fluid and it runs great either the injectors are returning too much fuel to the tank meaning bad injectors or a engine control module not controlling FPR correct. So this meanwhile, crank the engine for 15 seconds 3 times in a row, if it start you need new injectors. Remove the glow plugs and the ignition 1 relay, crank the engine over with a white napkin by the glow plugs ports, if you get a mist replace the injector. Not much else we can do with out a scanner. Thanks

Related GM Questions