How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Ron Your Own Question
Ron
Ron, ASE Certified Technician
Category: GM
Satisfied Customers: 33482
Experience:  34 year as An ASE certified Tech
7276279
Type Your GM Question Here...
Ron is online now
A new question is answered every 9 seconds

I had a service air suspension come on the dash and I

Customer Question

i had a service air suspension come on the dash and I replaced the level sensor and it went away. But the compressor wont level the hummer. When I have someone press the ride height button I can feel relay click but the compressor still doesnt turn on. If I remove the relay and run a wire between the 2 large pins the compressor kicks on. Not sure what is going on.
Submitted: 1 year ago.
Category: GM
Expert:  Ron replied 1 year ago.

Hello, my name is ***** ***** I am a professional here at Just Answer. I have noticed that your question was not getting a response and thought I would see if you still need help with this.I apologize for the delay and I hope I can still assist you with this here.

In order to try and help you determine why your compressor is not running I need to know what year you working on as well as have you scanned the system and retrieved the fault code and or codes that should be setting when the suspension system fails. If you can get the scan done and post back with the fault code and or codes as your model year I will try and help you get this resolved.

Customer: replied 1 year ago.
04 Hummer, I had it scanned before and was told the left level sensor was bad. So I replaced it and the "service air suspension" went away on the dash. But the compressor still doesnt turn on.
Expert:  Ron replied 1 year ago.

Can you have it scanned again and see if there are nay fault codes setting and get me the actual codes?