How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Gary Your Own Question
Gary
Gary, GMC Technician
Category: GM
Satisfied Customers: 16212
Experience:  15 years gm master tech/15 years ASE master tech
19513769
Type Your GM Question Here...
Gary is online now
A new question is answered every 9 seconds

I: i have a 2000 gmc yukon denali that has been tricky to

Customer Question

i Dave: i have a 2000 gmc yukon denali that has been tricky to start for several months two service centers cant find anything wring with it . After starting it misses for a short while then when hot it runs great. now today after cold weather 60deg it will not start after repeated tries. I even shot starter fluid in air intake but no luck any ideas to fix this thing? battery is good. Carl
Submitted: 1 year ago.
Category: GM
Expert:  Gary replied 1 year ago.

if you spray some starting fluid right down the throttle body butter fly it still will not even run a bit on the spray ?

does it have spark at the spark plug wires when cranking it over ?

Customer: replied 1 year ago.
Havent sprayed down the throttle body to avoid pulling alot of stuff off =. willdo and let you know. will also check spark. more after i do these things. Carl
Expert:  Gary replied 1 year ago.

ok sounds good

this engine need spark and fuel and compression to run we have to see which one is missing

Customer: replied 1 year ago.
did both things spray in carb and check good spark - still wont fire carl
Expert:  Gary replied 1 year ago.

can you pull a few plugs and see if they are gas soaked or very wet ?

Customer: replied 1 year ago.
but it is raining now will have to wait till rain stops probably tomorrow. how do i contact you then?
Expert:  Gary replied 1 year ago.

i would pull a few plugs if they are wet or soaked replace the plugs and see if it will run if it does then the plugs where bad if this starts to act up again you have to be sure the TPS and the ECT sensors are reading correctly with a scan tool and most common check the fuel pressure regulator as these are very common for being bad allowing fuel to leak through them into the vacuum hose that connects to the regulator and allows fuel to get into the intake and can flood out the engine or cause hard starting

you can always get me back through this post for FREE anytime with any follow up anytime with this question even after you rate us here at Justanswer !

Customer: replied 1 year ago.
will do carl
Expert:  Gary replied 1 year ago.

sounds great

dont forget to rate us here at Justanswer !

Expert:  Gary replied 1 year ago.

how are you making out ?

Expert:  Gary replied 1 year ago.

how are you making out ?

dont forget to rate us here at Justanswer !