How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask FIXITMAN Your Own Question
FIXITMAN
FIXITMAN, Master Technician
Category: GM
Satisfied Customers: 17144
Experience:  ASE Master Certified
1627031
Type Your GM Question Here...
FIXITMAN is online now
A new question is answered every 9 seconds

GM SILVERADO: 2005 5.3 LITER CHEVY SILVERADO NO START NO SPARK

Customer Question

2005 5.3 LITER CHEVY SILVERADO NO START NO SPARK NOW CRANK SENSOR RAB THREE DAYS BACK IN SAME CONDITIONS NO RPM REF NO START
Submitted: 1 year ago.
Category: GM
Expert:  FIXITMAN replied 1 year ago.
Hello my name is***** you tell me if the engine has always cranked over fine.
Customer: replied 1 year ago.

YES ALWAYS REPLACED SENJSOR RAN FINE FOR TWO DAYS NOW SAME CONDITION

Expert:  FIXITMAN replied 1 year ago.
Thank you. Is the security light on when cranking the engine?
Customer: replied 1 year ago.

ILL CHECK OK ILL KEEP YOU INFORMED

Customer: replied 1 year ago.

NO LIGHT ON HAS GOOD FUEL PRESSURE JUST LIKE NO SPARK

Expert:  FIXITMAN replied 1 year ago.
Have you checked for spark?
Customer: replied 1 year ago.

NO SPARK ON ANY PLUGS OK

Expert:  FIXITMAN replied 1 year ago.
If there is no spark then you either have a circuit issue or a problem with the computer. Most of the time this is caused by a loose ground connection on one of the cylinder heads or a fuse that has failed. Do you happen to have a voltage meter to run some tests?
Customer: replied 1 year ago.

YES WE DO WE ALSO REPLACED THE CAM SENSOR ITS NEW TO WHAT TEST DO WE NEED TO DO WE HAVE GOOD CAM SIGNAL NO CRANK AND NO SPARK

Customer: replied 1 year ago.

IS THERE GROUNDS ON BOTH HEADS

Expert:  FIXITMAN replied 1 year ago.
Most will have a ground on the rear of the driver head and the front of the passenger head. With the key on also let me know what the voltage reading is at the pink wires at then coils.
Customer: replied 1 year ago.

OK 11.96 OK

Expert:  FIXITMAN replied 1 year ago.
Did you check ground #2 shown? If this is a good ground then you either have a circuit issue from the crank sensor or the computer is failing.
Customer: replied 1 year ago.

OK SORRY TOOK SO LONG TO GET BACK FOUND A BROKEN WIRE ON LEFT LOWER BLOCK REPLACED CRANK SENSOR WITH A AC DELCO ONE WILL START NOW BUT WONT REV UP THEN DIES I WAS WOUNDERING THEY REPLACED THE CAM SENSOR COULD INTAKE GASKET BE LEAKING NOW

Expert:  FIXITMAN replied 1 year ago.
It is possible that it is leaking. Is the check engine light on while the engine is running?
Customer: replied 1 year ago.

NO STARTS RIGHT UP WONT REV UP PAST 1200-1500 THINKING PLUGGED CONVERTER ALMOST NOTHING COMES OUT OF TAILPIPE