How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask GM Bob Your Own Question
GM Bob
GM Bob, ASE Certified Technician
Category: GM
Satisfied Customers: 1074
Experience:  30 plus years experience as GM technician, ASE Master Technician and GM Certified.
70078276
Type Your GM Question Here...
GM Bob is online now
A new question is answered every 9 seconds

GM Buick Lacrosse CSX: I've been having issues last

Customer Question

I've been having issues for the last year with my 2010 Buick Lacrosse CSX. Just had it at the dealer for the 7th time trying to find a ghost. The car has high miles (270K mostly highway) so GM just blows me off but it is only a 4.5 year old vehicle that has been dealer serviced the entire time. The issue starts with Service Stabilitrack, Service Suspension, Service Parking Assist, and then finally Reducing Power ! By the time this happens the Engine Light comes on and there can be anywhere from 2 to 14 codes on. It loses Comms with Bus A, the throttle, the transmission, etc. Also, the gauges go back and forth and eventually go to zero or off while driving. The car acts like the movie Christine. It is a safety issue when the transmission loses comms and/or Reduced Power engages as I have had several sudden, violent slow downs. When there are alot of codes it will sometimes not start when pushing the Start button (and the brake is hard). I have resorted to disconnecting the battery, let
Submitted: 1 year ago.
Category: GM
Expert:  GM Bob replied 1 year ago.
Hello my name is ***** ***** had to find. Do you have the list of codes?I did find this bulletin here is a link to it.https://www.dropbox.com/s/4sh4u1o59rtdtwv/2010_LaCrosse_.png?dl=0
Customer: replied 1 year ago.
I believe the bulletin that you reference was the reason the ECM and BECM was replaced and reprogrammed. The dealer was very confident that it would solve the problem but the issues resumed about 3 days later. This week the dealer service tech cleared all the codes and replaced a large GMLan wire harness but the engine light came back during the test drive. The following five history codes remain: C0561-71 ; U2099-5A ; U0073 ; P0856 ; and U0100. The U0073 and U0100 have been consistently there since the issue started.
Expert:  GM Bob replied 1 year ago.
I have found two more bulletins
This one is for All Wheel drive
https://www.dropbox.com/s/8lij0z6wqgkbdu0/2010_LaCrosse_AWD.png?dl=0
This one is for a rubbed through wire.
https://www.dropbox.com/s/g7wdx1fp20v4ggf/2010_LaCrosse_rubbed_through.png?dl=0
Let me know if this has been done
Customer: replied 1 year ago.
Thanks Bob. I'm going to check and get a listing of all service records so I can track what has been done. I'll let you know once I get it. I'm also going to run both TSB's by the tech.
Expert:  GM Bob replied 1 year ago.
Sounds good
Thank you