How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask EricFromCT Your Own Question
EricFromCT
EricFromCT, Ford Technician
Category: Ford
Satisfied Customers: 3523
Experience:  20 years dealership exp., ASE A1-A9 L1 L2, Ford Lincoln Mercury Senior Master, Diesel Certified
34559540
Type Your Ford Question Here...
EricFromCT is online now
A new question is answered every 9 seconds

I have a 2011 F150 6.2L & I replaced the ABS module because

This answer was rated:

I have a 2011 F150 6.2L & I replaced the ABS module because it was physically in a front end collision. My problem is that I programmed it using FMP software and I have 2 codes B1596 & P258A. I don't understand why I have the P258A code if this vehicle doesn't have a vacuum pump & according to info. only the 3.5 liter has a vacuum pump.

Hi. I am a Ford dealer mechanic for 20 years. I was checking the codes you have listed. I do not come up with a p258a code. Could that be the wrong code?

Customer: replied 3 months ago.
no its P258A- Vacuum pump control circuit/ open

Ok. I see that code now.

It sounds to me that perhaps the module programming caused the module to think it is equipped with a vacuum pump. The abs module is what controls the vacuum pump. Did you get a used abs module? How did you program it again? I only program using the dealer tool. I am a little unfamiliar with the aftermarket ways to program.

Customer: replied 3 months ago.
I used a caraq m programmer and the module is new so when I programmed it pulled the as built data automatically

That is odd. Have you had the truck since new?

Customer: replied 3 months ago.
no it a auction vehicle

Can I have the VIN number to run it with Ford?

Customer: replied 3 months ago.
ok give me a few minutes

Ok

Customer: replied 3 months ago.
Vin# *****

That VIN is for a 2004 Explorer.

Your question says its for a 2011 F150?

Customer: replied 3 months ago.
correct sorry

Can I have the correct vin?

Customer: replied 3 months ago.
here we go Vin# *****

Thanks.

The truck definitly came with a 6.2

Do you have the ability to manually enter the as-built data?

Customer: replied 3 months ago.
it will it ask me that

I can get you the asbuilt that you can try to manually enter or compare to what was entered.

Has the truck had a new pcm? I wonder if bringing that to the latest level for that VIN could help.

Or is it possible that the truck has wiring for the vacuum pump even though there is no pump. Maybe the wires could be there and damaged and being sensed by the abs module. You could check behind the left hand headlamp to see if the wiring for it is there.

Customer: replied 3 months ago.
I'm going to check ok and so do you I reprogram this module and manually enter the as built data. I will also check behind the light. But am I correct in saying that did vehicle should not be equipped with a vacuum pump

Yes. There should not be a vacuum pump. Only on a 3.5 turbo ecoboost. If the problem lies in the abs module, I think you need to verify it has the correct as built installed so it knows the truck is not equipped with a pump.

Customer: replied 3 months ago.
ok got it Can you give the as built data

Yes. The ford site is down for a moment. I will keep trying.

Customer: replied 3 months ago.
ok thanks

i dont know whats up with the ford site, but i will get the info for you when it comes back up

ABS 760-01-01(###) ###-####1

ABS 760-01-02 314536384290

ABS 760-01-03 464131303689

ABS 760-01-04(###) ###-####9

ABS 760-01-05 3E00002323F1

ABS 760-01-06 000002911011

Customer: replied 3 months ago.
ok thanks alot I will give it a shot & I'll get back to you in a bit ok

sounds good

Customer: replied 3 months ago.
I tried as built and same codes pop up

Does the codes turn on the ABS light?

Customer: replied 3 months ago.
no only the brake light & it says check brake system

I am running out of ideas on why that would be happening. DId you check the area where a pump would be? perhaps check the wiring?

Customer: replied 3 months ago.
I'm going to do that next I had to step real quick

alright

Thank you foir viewing my response. If you have any more questions let me know. Also please take the time to rate my assistance.

EricFromCT and other Ford Specialists are ready to help you
Customer: replied 2 months ago.
hey hope all is well and that you had a blessed holiday. I'm back on this truck I'm going to check to see if the wire is coming out of the abs unit
Customer: replied 2 months ago.
If I'm not mistaken it's pin 36 GY/VT
Customer: replied 2 months ago.
Hey Eric I'm still messing around with this truck do you think it might be an issue with the as built data. Is there any one I can talk to at Ford about the programming file

Related Ford Questions