How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Ron Your Own Question
Ron
Ron, ASE Certified Technician
Category: Ford
Satisfied Customers: 23001
Experience:  23 years with Ford specializing in drivability and electrical and AC. Ford certs and ASE Certs
7276279
Type Your Ford Question Here...
Ron is online now
A new question is answered every 9 seconds

Installed multiple steering pumps-racks-and hoses-power

Customer Question

installed multiple steering pumps-racks-and hoses-power steering fluid still spews thru the reservoir
Submitted: 14 days ago.
Category: Ford
Expert:  Chad Farhat replied 14 days ago.

Hi, I'm Chad. Welcome to JustAnswer. I'm reviewing your question and I will be posting your reply ASAP.

Expert:  Chad Farhat replied 14 days ago.

hey how are you

1- are the pump & the rack new ?

2- are you installing the hose line( high pressure & return line

correctly ?

3- you are building pressure & pushing fluid out ?

Please let me know

Thank You

Chad Farhat

ASE Certified Technician

Customer: replied 14 days ago.

vehicle been in shop three weeks no matter what happens after five minutes it spews thru reservoir

Expert:  Chad Farhat replied 14 days ago.

ok , well you don't want to hear this , but sounds you are building pressure ( Blown head gasket )

Please let me know if you need anything else

Thank You

Chad Farhat

ASE Certified Technician

Customer: replied 14 days ago.

strictly steering fluid blowing thru reservoir -antifreeze is good and fans turn on vehicle problem is strictly steering and its a 99 escort cant afford new rack new pump used aftermarket

Expert:  Chad Farhat replied 14 days ago.

sorry lats comment was not meant for you sorry . not a blown head gasket,was for a different car .

i believe the rack you got is the issue , it is building pressure .go get another ,you should have 30 days warranty even if used

Related Ford Questions