How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask AMEDEE Your Own Question
AMEDEE
AMEDEE, FORD TECHNICIAN
Category: Ford
Satisfied Customers: 24396
Experience:  ASE CERTIFIED TECHNICIAN ADVANCED LEVEL SPECIALIST. Wisconsin certified emissions state inspector
279429
Type Your Ford Question Here...
AMEDEE is online now
A new question is answered every 9 seconds

I HAVE A 4.2 IT HAVE NO POWER AND HESITADE AT ACCELARATION

Customer Question

I HAVE A 4.2 IT HAVE NO POWER AND HESITADE AT ACCELARATION NO CK ENGINE LIGTH
JA: Is the power loss consistent, or does it fluctuate?
Customer: CONSISTENT
JA: What is the model/year of your Ford?
Customer: 2000 F150 4.2
JA: Are you fixing your F150 yourself? What have you tried so far?
Customer: YES I REPLACE TRANSMISSION
JA: Anything else you want the mechanic to know before I connect you?
Customer: NO JUST THAT
Submitted: 16 days ago.
Category: Ford
Expert:  AMEDEE replied 16 days ago.

Hello and welcome!

My name isCustomerand I can assist you with your question.

Expert:  AMEDEE replied 16 days ago.

Are you looking for possible causes?

Customer: replied 16 days ago.
Expert:  AMEDEE replied 16 days ago.

NO problem.

I will be happy to help!

Here are the three most likley possible causes

1. Mass air flow sensor

2. Low fuel pressure

3. Plugged exhaust.

Expert:  AMEDEE replied 16 days ago.

I am glad I can help!

It has been a pleasure working with you. Please dont forget to honor your good faith deposit by rating my answer as "5 STAR SERVICE" for assisting you today.

Keep in mind, we can still continue this conversation at no further cost to you even after you rate my answer. Just reply back to me using this page and I will get it and get back to you ASAP!

Also, if you are a member or if you have a subscription to the site, you still need to rate my answer in order for me to get credit for assisting you with your question.

Please let me know if you have any further questions.

Customer: replied 16 days ago.
I replaced mass air flow sensor and fuel filter and exhaust is free flow
Expert:  AMEDEE replied 16 days ago.

Excellent!

What is the oxygen sensor readings at under a load?

Customer: replied 16 days ago.
that I have no idea
Expert:  AMEDEE replied 16 days ago.

How about exhaust back pressure or fuel pressure?

Customer: replied 16 days ago.
the engine revs real good in parking but when you put it in drive it has no power
and it have slow take off
Expert:  AMEDEE replied 16 days ago.

Right, this is most likley caused by a sever lean condition.

You can also check the air intake snorkle from the mass air flow sensor to the throttle body to ensure it is not cracked or ripped in anyway.

Customer: replied 16 days ago.
I did and I also spray starting fluid on top of all the vacuum lines on intake and no changes
Expert:  AMEDEE replied 16 days ago.

Ok, excellent!!

Customer: replied 16 days ago.
what I do next?
Expert:  AMEDEE replied 16 days ago.

Check the fuel pressure.

Customer: replied 16 days ago.
ok ill di that tomorrow
Expert:  AMEDEE replied 16 days ago.

Sounds good!

I am glad I can help!

Please dont forget to rate!

Have a great night!

Expert:  AMEDEE replied 14 days ago.

Hello! It'sCustomerfrom just answer.

I am just checking in to see if you need any further assistance?

Let me know!

Related Ford Questions