How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask AMEDEE Your Own Question
AMEDEE
AMEDEE, FORD TECHNICIAN
Category: Ford
Satisfied Customers: 24409
Experience:  ASE CERTIFIED TECHNICIAN ADVANCED LEVEL SPECIALIST. Wisconsin certified emissions state inspector
279429
Type Your Ford Question Here...
AMEDEE is online now
A new question is answered every 9 seconds

09 ford focus 2.0l has no codes showing. It idles rough and

Customer Question

09 ford focus 2.0l has no codes showing. It idles rough and power surged when using accessories such as brakes lights radio heater and Windows.... when you use them it all seems to draw excessive power. Hooked up ODB2 reader and still no codes show but shows that it is drawing more power then it normally should and coolant is running at 77-78º.
JA: Have you checked the brake fluid? How's the level and when was it last changed?
Customer: Front brakes were just done fluids clean and topped
JA: Are you fixing your Focus yourself? What have you tried so far?
Customer: Yes oil and filter change
JA: Anything else you want the mechanic to know before I connect you?
Customer: The transmition also slips slightly turning corners and at a highway speed. And a humming noise from the front end
Submitted: 17 days ago.
Category: Ford
Expert:  AMEDEE replied 17 days ago.

Hello and welcome!

My name is ***** ***** I can assist you with your question.

Expert:  AMEDEE replied 17 days ago.

There are a few things that can cause this rough idle condition. I will list the most common for you.

The most common cause for this condition is a faulty mass air flow sensor, air or vacuum leak or faulty engine/motor mounts. Ford has a TSB for this condition caused by a faulty "dog bone" or motor mount. It is TSB 11-3-24.

Expert:  AMEDEE replied 17 days ago.

Another possible cause would be incorrect camshaft timing or a loose timing chain which can and will affect the engine idle. I would check engine vacuum to ensure is is nice and smooth and withing specifications. Also, dont forget about the spark plugs and ignition coils as they can cause the engine to misfire if they go bad. I have even seen these cause misfires without even setting a trouble codes in the computer.

Expert:  AMEDEE replied 17 days ago.

I am glad I can help!

It has been a pleasure working with you. Please dont forget to honor your good faith deposit by rating my answer as "5 STAR SERVICE" for assisting you today.

Keep in mind, we can still continue this conversation at no further cost to you even after you rate my answer. Just reply back to me using this page and I will get it and get back to you ASAP!

Also, if you are a member or if you have a subscription to the site, you still need to rate my answer in order for me to get credit for assisting you with your question.

Please let me know if you have any further questions.