How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Ron Your Own Question
Ron
Ron, ASE Certified Technician
Category: Ford
Satisfied Customers: 23001
Experience:  23 years with Ford specializing in drivability and electrical and AC. Ford certs and ASE Certs
7276279
Type Your Ford Question Here...
Ron is online now
A new question is answered every 9 seconds

My 1994 ford f150 4.9l engine/auto trans. runs fine until

Customer Question

my 1994 ford f150 4.9l engine/auto trans. runs fine until engine fully warmed up, then usually during up hill lugging (but not always) the engine seems to surge, miss and lose power along with sensation of the transmission disconnecting (this means that the rpm's can accelerate yet no speeding up occurs). I then stop off the road, shut engine off for 3 to 5 minutes (this seems to "reset" something) and I then get 1 to 5 miles of good strong power. then it starts all over again. vehicle/engine have 165000 miles.
Submitted: 1 month ago.
Category: Ford
Expert:  AMEDEE replied 1 month ago.

Hello and welcome!

My name isCustomerand I can assist you with your question.

Expert:  AMEDEE replied 1 month ago.

Is the check engine light on?

Are there any codes in the computer?

Are you looking for possible causes or would you like me to walk you through this diagnoses?