How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Ray M. Your Own Question
Ray M.
Ray M., Ford Master Tech
Category: Ford
Satisfied Customers: 3019
Experience:  30+ years in trade, Ford Master Tech, Journeyman Automotive Tech
11409661
Type Your Ford Question Here...
Ray M. is online now
A new question is answered every 9 seconds

I have 2005 ford 2500 6.0L no oil pressure, new oil pump no

Customer Question

I have 2005 ford 2500 6.0L no oil pressure
JA: How old is your oil pump? Has the check engine light come on?
Customer: new oil pump no light on
JA: Are you fixing your 2500 yourself? What have you tried so far?
Customer: I am a general mechanic. timing cover was licking and I replace timing cover gasket and oil pump
JA: Anything else you want the mechanic to know before I connect you?
Customer: I pull the oil filter and I see oil but slow pressure, my gauge do not show nothing
Submitted: 1 month ago.
Category: Ford
Expert:  david craig replied 1 month ago.

Hi I david, did you maybe forget to reconnect the oil pressure sensor?

Expert:  david craig replied 1 month ago.

With oil flowing in the filter housing, that is adecent indication your lpop is working ok. I would investigate/remove the ipr and check the screen for tears/holes. All your codes are an indication of hpo leak or failed ipr

Customer: replied 1 month ago.
My problem is that I have no oil pressure. In order to check the oil pressure, I have to remove the oil sensor. The oil pressure gauge is giving me a reading of zero oil pressure. I know that oil is getting into the oil filter. In order to get the truck running I need to have oil pressure. I reconnected the oil sensor....Also no check engine lights and no codes
Expert:  david craig replied 1 month ago.

is the truck starting and running?

Customer: replied 1 month ago.
no its not running
Expert:  david craig replied 1 month ago.

ok.

Expert:  david craig replied 1 month ago.

Pull out the ipr and inspect the screen.
I would start there first.
It's mounted under the turbo screwed into the hpop cover.

Expert:  david craig replied 1 month ago.

any luck?

Expert:  david craig replied 1 month ago.

do you still need assistance?

Expert:  Ray M. replied 1 month ago.

You may have to prime the low pressure oil pump to get it to supply pressure, I have had them where I had to remove the pump cover and pack the gears with bearing lube or lubriplate grease.

Customer: replied 1 month ago.
I don't need assistance thank you
Expert:  Ray M. replied 1 month ago.

Okay, I understand. Would you like me to close out this session then?

Related Ford Questions