How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Ron Your Own Question
Ron
Ron, ASE Certified Technician
Category: Ford
Satisfied Customers: 23001
Experience:  23 years with Ford specializing in drivability and electrical and AC. Ford certs and ASE Certs
7276279
Type Your Ford Question Here...
Ron is online now
A new question is answered every 9 seconds

2012 Ford edge Limited rear camera not woking, displays

Customer Question

2012 Ford edge Limited rear camera not woking, displays camera not available
JA: Are you fixing your Edge yourself? What have you tried so far?
Customer: looking at it since it is out of warranty and considering a new one soon. I have performed a sync reset several times. It works some times usually after a*****
JA: Anything else you want the mechanic to know before I connect you?
Customer: no
Submitted: 3 months ago.
Category: Ford
Expert:  Mat replied 3 months ago.

Hi I'm a Ford Senior Master Technician and I would like to help you out. Do you have access to a factory ford scan tool to perform the diagnostics on this system? They are required to properly diagnose these systems. The first thing we will need to do is pull codes from the Body Control Module (BCM) and the Accessory Protocol Interface Module (APIM). You have already tried a sync reset and that did not help. You can try to disconnect the battery for 5 min and this will perform a hard reset on the APIM. Most likely if everything else sync and radio related is working normal the APIM will be ok but you can try the hard reset to see if it helps. Since it displays camera not available this proves your FDIM (front display interface module module) is working properly. Since "Camera Not Available" is being displayed we can assume the BCM and FDIM are looking for it but are receiving no signal from the camera. This tells me your problem is most likely with the camera itself or circuits between the camera and the display. Do you paln on removing the cemera and radio display for further testing with a dvom meter? If you are I can tell you which wires to check for opens, shorts to power, shorts to ground etc. to narrow down your issue. If you need any further assistance let me know and I would be glad to help you out.

Thanks

Customer: replied 3 months ago.
I could remove the camera and check it and the display and check it also
Customer: replied 3 months ago.
I don't have the scan tool but will take it to the dealer and run the scan?
Expert:  Mat replied 3 months ago.

Ok if you wish to bring the car to the dealer and have it scanned for codes that would be great. Once we have the codes it will be easier to pin point your exact issue. Just make sure they print the codes directly from the scan tool or write them down and from which module the codes are stored in. They can do one quick Continuous memory scan for all dtc's in all modules so that may be the best. Once you get the codes let me know and I can help you with the diagnostics and get you the step by step test procedures. Thanks