How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Ron Your Own Question
Ron
Ron, ASE Certified Technician
Category: Ford
Satisfied Customers: 33477
Experience:  23 years with Ford specializing in drivability and electrical and AC. Ford certs and ASE Certs
7276279
Type Your Ford Question Here...
Ron is online now
A new question is answered every 9 seconds

It ran fine one day, well it would kind of load up at stop

Customer Question

it ran fine one day, well it would kind of load up at stop lights due to my hitting the o2 sensor when changing clutch, but it ran and i shut it off after i got it hooked to my van, towed it 400 miles then re hooked the batery and it kind of tried to start, then nothing. i am not geting any power to the fuel pump. i checked the relay and closed the contacts to make the pump run and got fuel. i have spark, but still no action
JA: Has the clutch been slipping? Are you having any trouble shifting?
Customer: no, its fine
JA: What is the model/year of your Ford?
Customer: 1986 ford ranger, 2.9 with a cam up, lol. good little truck 4by4
JA: Are you fixing your Ranger yourself? What have you tried so far?
Customer: i have fuel because i hotwired the pump, i checked for spark and was getting spark, but it wont fire
JA: Anything else you want the mechanic to know before I connect you?
Customer: i dont know about the pressure, but it is a new pump because i thought that was the problem
Submitted: 2 months ago.
Category: Ford
Expert:  Ron replied 2 months ago.

Hello. My name is ***** ***** I am happy to assist you today. Give me just a moment to review your post, and I'll be right back with the help you need.

Expert:  Ron replied 2 months ago.

Hello, my name is ***** ***** I am a professional here at Just Answer. I have noticed that your question was not getting a response and thought I would see if you still need help with this.I apologize for the delay and I hope I can still assist you with this here. In order for the engine to start and run you need good spark to the spark plugs, injector pulse at the injectors and proper fuel pressure (32 to 45 PSI). Since you are sure you have good spark as well as fuel pressure then the next steps would be to check and see if you have injector pulse. You can do this with a 12 volt test light by placing the test end into the power side of any one of the injectors and the ground end of the light ont he other wire and then crank the engine over. If you have injector pulse the light should flash. Check this for me and post back with the results and we can work from there.