How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Dan Your Own Question
Dan, ASE Certified Technician
Category: Ford
Satisfied Customers: 1087
Experience:  Dealer Auto Technician
Type Your Ford Question Here...
Dan is online now
A new question is answered every 9 seconds

We have a 2000 F450 Super duty...guys were driving it

Customer Question

We have a 2000 F450 Super duty...guys were driving it yesterday and all was running fine...they stopped and then there was no power to anything in the truck when they tried to start...tried switching batteries to no avail
Submitted: 30 days ago.
Category: Ford
Expert:  Dan replied 30 days ago.

Hello my name is***** am an ASE Master Technician and I am glad to help you out with your question.

Expert:  Dan replied 30 days ago.

Check battery cables for corrosion, check the main power cable that goes to the main fuse box make sure its not loose.

This sounds like a main power cable problem. Check the main fuse link as well, look for a 125 amp fuse. If it is blown it will cause this problem. Check the main battery cable ground and clean the ground if needed.

Expert:  Dan replied 30 days ago.

Please reply to this if you need more help and we can continue this conversation. This does not have to be my only answer. If you are satisfied with my service, please rate at the top of the screen. Rating does not close out your question. Remember, sometimes it is difficult to completely diagnose your vehicle without being there, but I will try to give you the best answer I can. Hoping to be giving you 5 star service.



Customer: replied 30 days ago.
We will start there...I will reply back when we complete these items
Expert:  Dan replied 30 days ago.

ok thanks

Customer: replied 29 days ago.
that fuse was in bad shape and one of the wires going to it was we replaced the fuse link and cleaned up the wire and reattached...we now have power in the truck but can hear relays turning on and off and the power can be erratic...if you turn the ignition to start it, it does not engage the guy mentioned that it can be affected by the door being open or closed...either way it sounds like we have power but some other connection issue
Expert:  Dan replied 29 days ago.

Check the small wire on the starter for voltage when the key is turned to start, try jumping the starter solenoid and see if it turns over.

Expert:  Dan replied 23 days ago.

Hello again Dan here,

I am contacting you because the post has not been closed or rated.

This question is coming up on 7 days which means it will time out and close.

You have already paid to get this question answered, but you have not rated.

Let me help some more. Is there anything else I can help you with?

If I did not give you 5 star service, please let me know what I missed.