How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Ron Your Own Question
Ron
Ron, ASE Certified Technician
Category: Ford
Satisfied Customers: 23001
Experience:  23 years with Ford specializing in drivability and electrical and AC. Ford certs and ASE Certs
7276279
Type Your Ford Question Here...
Ron is online now
A new question is answered every 9 seconds

Both front power windows stopped working at the same time. I

Customer Question

both front power windows stopped working at the same time. I just replaced the switch pod with a used one and the problem continues
JA: Have you checked the fuses?
Customer: i checked both fuses inside the cabin
JA: What is the model/year of your Ford?
Customer: 2005 marquis
JA: Are you fixing your Marquis yourself? What have you tried so far?
Customer: just the fuses and replacing the switch pod - myself
JA: Anything else you want the mechanic to know before I connect you?
Customer: no
Submitted: 2 months ago.
Category: Ford
Expert:  Ron replied 2 months ago.

Hello. My name is ***** ***** I am happy to assist you today. Give me just a moment to review your post, and I'll be right back with the help you need.

Expert:  Ron replied 2 months ago.

Do both windows not work from either the drives door switch or the passenger door?

Customer: replied 2 months ago.
correct
Expert:  Ron replied 2 months ago.

Are you able to do some testing If I provide you with the steps starting with checking for power in and out of the master switch?

Customer: replied 2 months ago.
I'm not overly mechanical. how complicated are the steps?
Expert:  Ron replied 2 months ago.

If you nor mechanical you may need some hands on help performing the steps. Do you have access to someone who can help you with these steps?

Customer: replied 2 months ago.
no, it;s just me.
Expert:  Ron replied 2 months ago.

well unfortunately with out proper testing there is no easy answer. Im suspecting you may have a bad Accessory delay relay but its a guess with out the testing.

Customer: replied 2 months ago.
OK. I know the relays are in the box under the hood and I'm not willing to f-up under there. Thanks for your help, anyway.
Expert:  Ron replied 2 months ago.

Your very welcome and if you can get someone to help you with some hands on testing I can provide the steps.

Customer: replied 2 months ago.
cheers
Expert:  Ron replied 2 months ago.

You as well.