How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Ron Your Own Question
Ron
Ron, ASE Certified Technician
Category: Ford
Satisfied Customers: 33481
Experience:  23 years with Ford specializing in drivability and electrical and AC. Ford certs and ASE Certs
7276279
Type Your Ford Question Here...
Ron is online now
A new question is answered every 9 seconds

Front climate control blower not working on any speed.

Customer Question

Front climate control blower not working on any speed. Changed blower control in plenum, but still nothing
JA: What is the model/year of your Ford?
Customer: 2010 Ford expedition Eddie Bauer
JA: Are you fixing your Expedition yourself? What have you tried so far?
Customer: That was in my initial message
JA: Anything else you want the mechanic to know before I connect you?
Customer: No
Submitted: 2 months ago.
Category: Ford
Expert:  Ron replied 2 months ago.

Hello. My name is ***** ***** I am happy to assist you today. Give me just a moment to review your post, and I'll be right back with the help you need.

Expert:  Ron replied 2 months ago.

Are you working on a Manuel system (knobs) or an automatic (buttons) ?

Customer: replied 2 months ago.
Auto
Customer: replied 2 months ago.
I added a couple photos for id s well
Expert:  Ron replied 2 months ago.

And you have already replace the blower motor speed controller?

Customer: replied 2 months ago.
I think this is the blower motor relay
Customer: replied 2 months ago.
Here
Customer: replied 2 months ago.
Any way to test the relay before swapping in new one?
Expert:  Ron replied 2 months ago.

Okay that is the relay , the more common cause for the blower to fail providing the blower motor is okay is usually a failed blower motor speed controller and not the relay. Before you replace any more parts are you able to do some testing for the blower motor speed controller?

Customer: replied 2 months ago.
but like I said, it was replaced with new. I have both right here
Customer: replied 2 months ago.
As an aside, this control was replaced just a little over a year ago when I only had high speed control
Expert:  Ron replied 2 months ago.

Well let start with rechecking it to be sure it has not failed. See the steps in the link below.

https://dl.dropboxusercontent.com/u/104923897/Speed%20test%20Sept%2012.pdf

https://dl.dropboxusercontent.com/u/104923897/Jump%20test%20sept%2012.pdf

If it passes the testing then the nest steps would be to check the blower and the circuit to t.

See those steps here as well as the wiring diagram for testing reference. Start your testing for the blower on P1.

https://dl.dropboxusercontent.com/u/104923897/Blower%20motor%20wiring%20sept%2012.pdf

https://dl.dropboxusercontent.com/u/104923897/Blower%20motor%20Sept%2012.pdf