How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Chad Farhat Your Own Question
Chad Farhat
Chad Farhat, ASE Certified Technician A6 - Electrical / Electronic systems A7 Heating / Air conditioning systems
Category: Ford
Satisfied Customers: 1226
Experience:  Owner at Carolina Auto Service & Sales , 20 years experience in Foreign & Domestic Vehicles
Type Your Ford Question Here...
Chad Farhat is online now
A new question is answered every 9 seconds

2003 windsstar....electrical issues, yes windstar 6 cyl, I

Customer Question

2003 windsstar....electrical issues
JA: What is the model of your '03 Ford?
Customer: yes windstar 6 cyl
JA: Are you fixing your Windstar yourself? What have you tried so far?
Customer: I am not sure....last nite the lights would not go I had a friend disconnect the battery. When we plugged it back in today the head lights were flashing removed key and heard clicking...all dashboard controls are out of wack...says tach 7....temp hot....etc
JA: Have you checked the fuses? The dashboard bulbs?
Customer: my friend checked the fuses under front drivers side dash and nothing helped.
JA: Anything else you want the mechanic to know before I connect you?
Customer: this has been acting was flashing and dash lights are intermittent
Submitted: 1 month ago.
Category: Ford
Expert:  Chad Farhat replied 1 month ago.

Hi, I'm Chad. Welcome to JustAnswer. I'm reviewing your question and I will be posting your reply ASAP.

Customer: replied 1 month ago.
Hi Chad....thank you! I am not a mechanic...
Expert:  Chad Farhat replied 1 month ago.

you welcome , its okay , we will try

1- do we have 12 volt on battery and at turn of switch to start do you still have 12 volt on it ,using a voltmeter

2- is there a red security flashing light on dash or steady on ?

3- is your security alarm triggered ?

4- do youhave one or 2 keys for the van

Please let me know

Thank You

Chad Farhat

ASE Certified Technician

Customer: replied 1 month ago.
I don't have a voltmeter.
Right now the battery is disconnected
Customer: replied 1 month ago.
What I need is some advice on what to have my mechanic check after I have it towed to him
Customer: replied 1 month ago.
I do have keys...
Customer: replied 1 month ago.
two keys but only one of them works as a remote
Expert:  Chad Farhat replied 1 month ago.

1- check battery for 12 volts

2- alternator charging 14 volts when running

3- the headlight flashing & relay clicking , tells me low voltage ,

4- scan the vehicle with ford scanner or equivalent & retrieve any fault codes from engine module & antitheft module

if the battery low it will trigger the alarm ,it seems that is what happened but testing is needed .

You can try the below procedure , but if battery bad or weak it want work ,if it is an alarm issue

Master reset Procedure

1- Disconnect battery Cables ( Negative & Positive Cables )

2- Hold cables Together for 60 secs ,then let go

3- Wait 15 minutes

4- Make sure all doors are closed

5- Reconnect battery Cables

6- Lock & unlock the vehicles using the key from driver door side (if you have a key fob with no blade key, just lock & unlock using the key fob buttons)

7- Enter the vehicle and attempt to start

Let me know if you need anything else on it , just reply back here & we can continue.

if you are good , Please Kindly rate me.

Hope I was helpful to you

A Positive Rating is Much Apreciated

This Post Will Stay Open for You To Come back and Ask me Any Follow Up Question You May have on this issue , even after you rate me

Thank You

Chad Farhat
ASE Certified Tedchnician

Customer: replied 1 month ago.
Thank you.....I will take this to my mechanic tomorrow and get back to you.
Expert:  Chad Farhat replied 1 month ago.

you welcome sounds good

just let me know

Thank You


Customer: replied 1 month ago.
Chad was quick to answer my question but unfortunately his fix did not help the issue.
Expert:  Chad Farhat replied 1 month ago.

I m really sorry about that

I tried ,hope you got it fixed

Thank You


Customer: replied 1 month ago.
HI Chad....thank you for your help....and I did get the issue fixed (for now)...but this vehicle has some major electrical issues...and didn't expect that this simple fix would be "the fix"...Thanks again. Wendy
Expert:  Chad Farhat replied 1 month ago.

you welcome i m glad you got fix it Wendy .

please don't forget to rate me before you exit ,please be kind no 2 or 1 .

sorry my fix did not fix it but i m glad you got it fixed & it was not a major thing for you .

I did respond quickly though :)

Thank You

Chad Farhat