How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask sprinkles08 Your Own Question
sprinkles08
sprinkles08, ASE Certified Technician
Category: Ford
Satisfied Customers: 21797
Experience:  ASE Master and Advanced level certified. Factory trained with 15 years dealership experience
9825021
Type Your Ford Question Here...
sprinkles08 is online now
A new question is answered every 9 seconds

2006 Ford Explorer Eddie Bauer, Having issues with airbag

Customer Question

2006 Ford Explorer Eddie Bauer
Hello Chris,
Having issues with airbag light coming on intermittently. Sometimes this is followed by other warning lights, but lately it has just been the airbag light.After shutting car of it will not restart. (No click) It will jumpstart. I also noticed that when turning to forward position before start position the message center will turn green for a second and then turn red showing a battery symbol. The car starts with no issues if not turned off after airbag light comes on. I have read many possible causes.
It is not the battery or the alternator.
Thanks,
Ed
Submitted: 4 months ago.
Category: Ford
Expert:  John Vieira replied 4 months ago.

Hello and welcome, My name is ***** ***** I will be working with you on the issue ar hand.

Customer: replied 4 months ago.
Hello
Customer: replied 4 months ago.
Thank you
Expert:  sprinkles08 replied 4 months ago.

Hello and welcome to JustAnswer!

You could have quite a few things going on and you may have more than one problem. The warning lights are coming on because fault codes are setting in the systems' respective modules. If a jump start i required then you either have a bad battery, possibly a charging system issue or a connection issue between the battery and cables.

The first step in diagnosing the problem is to use a scan tool to see what fault codes are setting in each module. Do you know what codes are setting?

Customer: replied 4 months ago.
Hello,Battery has been replaced twice and cables have been checked. Alternator is putting out 14 volts so that does not seem to be the issue. No codes are coming up. Car starts and runs fine for weeks at a time. This issue always starts with the airbag light. If the airbag light goes on and stays on the car will not start after shutting off. There is no click but all accessories work.Thanks,
Ed
Customer: replied 4 months ago.
Here is a photo of when it is at its worst. We drove the car home like this and it seemed to run just fine. This has not happened for a few weeks. The airbag light is always the first to come on.
Customer: replied 4 months ago.
When all of these lights are on and you are driving the car the speedometer and tachometer are not warming.
Expert:  sprinkles08 replied 4 months ago.
The reason warning lights come on is because fault codes set. How are you trying to check for codes?
Customer: replied 4 months ago.
After the car is shut off and turned back on it looks like everything must be resetting back to normal. We used a small scanner and also had the car at a garage for 2 weeks that had a more detailed scanner. No codes come up. I will try and have it scanned before shutting it off next time it happens.
Expert:  sprinkles08 replied 4 months ago.

Fault codes don't clear unless done with a scan tool or battery voltage is lost. What is the actual brand and model of what you're using?