How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Chris (aka- Moose) Your Own Question
Chris (aka- Moose)
Chris (aka- Moose), Technician
Category: Ford
Satisfied Customers: 44462
Experience:  16 years experience
2499435
Type Your Ford Question Here...
Chris (aka- Moose) is online now
A new question is answered every 9 seconds

My headlights, brake lights, turn signals, hazards nor

Customer Question

My headlights, brake lights, turn signals, hazards nor wipers work. I replaced the Body control module yesterday!
JA: Have you checked the fuses? Have you checked the bulbs?
Customer: Yes all the fuses are ok
JA: What is the model/year of your Ford?
Customer: 2001 supercrew 4x2 4.6L
JA: Are you hoping to fix this yourself? What have you tried so far?
Customer: Yes. I have had a recent problems with the battery saver relay blowing so I replaced the BCM. It was brand new, already programmed. I installed it and automatically fuse #15 on the interior panel blew. Tried a new fuse and it blew it. Narrowed the problem to the cruise control switch next to the brake booster. Installed a brand new one, then the light problem happened. I've checked all the fuses and relays and everything looks good.
JA: Anything else you think the mechanic should know?
Customer: After the truck sits for a little while, the battery becomes weak and it has to be jumped. This is my first ford and I've never approached this problem, so I may be missing something.
Submitted: 3 months ago.
Category: Ford
Expert:  Chris (aka- Moose) replied 3 months ago.

Welcome, I'm Chris (aka Moose) I prefer to work when others don't, I am here around lunch and after dinner till after midnight.

Do you have a volt meter?

At the speed control deactivation switch, is or was there brake fluid in the connector?

When you replaced the GEM module was there any sign of rust or water in that area?

Expert:  Chris (aka- Moose) replied 3 months ago.

Hello again Chris here,

  • I am following up with you to see if you got everything you needed from my answer. We're you pleased with my help?
  • If you were not pleased with my help, please let me know by replying so I can help more.
  • This post is coming up on the 7 day mark where it times out. When a post times out, that means it's no longer on my active list (you reply and I may never know it.)

Thanks Chris