How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Chris (aka- Moose) Your Own Question
Chris (aka- Moose)
Chris (aka- Moose), Technician
Category: Ford
Satisfied Customers: 44522
Experience:  16 years experience
2499435
Type Your Ford Question Here...
Chris (aka- Moose) is online now
A new question is answered every 9 seconds

2001 explorer sport 4cyl car running rough when in drive it

Customer Question

2001 explorer sport 4cyl car running rough when in drive it loses power and stalls out in park at higher rpms it smooths out. I chained ignition wires still the same.
Submitted: 3 months ago.
Category: Ford
Expert:  david craig replied 3 months ago.

Hi Im David and will be assisting you today. The very first ting that I do with vehicles acting like this is look to see if the check engine light is on.

Customer: replied 3 months ago.

yes it is

Expert:  david craig replied 3 months ago.

Ok. you need to see why it is on. do you have a code reader?

Customer: replied 3 months ago.

no .

Expert:  david craig replied 3 months ago.

you need to take it to a shop or an autoparts store to have the computer scanned for fault codes. a shop will charge for the diagnostic, an auto parts store like Advance Auto will do it for free. Then we can go from there.

Expert:  david craig replied 3 months ago.

or you can can replace the spark plugs, clean the maf, iac, egr and throttlebody to see if that remedies your problem.

Customer: replied 3 months ago.

I disconnected battery yesterday so check engine light is off . i may have cleared the codes with the reader the only code right now is bank 1 system too lean, pending. also gas cap was missing and we had rain so i got a new cap and added some sea foam. car runs ok on level roads but hills loses power.

Expert:  david craig replied 3 months ago.

a vacuum leak test needs to be done also then, theres to much air getting into the engine. usually caused by a vaccum leak or air getting in the intake pst the maf sensor.

Expert:  david craig replied 3 months ago.

were you able to get the codes?

Expert:  david craig replied 3 months ago.

do you still need assistance??

Expert:  david craig replied 3 months ago.

hello????

Expert:  Chris (aka- Moose) replied 3 months ago.

Welcome, I'm Chris (aka Moose) I prefer to work when others don't, I am here around lunch and after dinner till after midnight.

The previous tech has opted out. Would you like me to help with this possible air fuel ratio concern?

This is my 1st answer, but does not have to be my only answer. You the website and myself expect you to have a great experience with my help. Please let me know if you are pleased by selecting a star rating above or by replying and saying your pleased. Not rating or rating 1-2 stars does not benefit you nor me in any way. Follow up and reply as often and when needed, there is no extra charge to do so.

Thanks Moose.

Expert:  Chris (aka- Moose) replied 3 months ago.

Hello again Chris here,

  • I am following up with you to see if you got everything you needed from my answer. We're you pleased with my help?
  • If you were not pleased with my help, please let me know by replying so I can help more.
  • This post is coming up on the 7 day mark where it times out. When a post times out, that means it's no longer on my active list (you reply and I may never know it.)

Thanks Chris

Related Ford Questions