How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask James Your Own Question
James, Ford Technician
Category: Ford
Satisfied Customers: 3545
Experience:  Ford Senior Master Tech, Ford gas and diesel expert, ASE Certified
Type Your Ford Question Here...
James is online now
A new question is answered every 9 seconds

Hard start no power rough idle right bank not firing no heat

Customer Question

hard start no power rough idle right bank not firing no heat at manifold on right bank temp about 80 left bank temp about 170
JA: Is the power loss consistent, or does it fluctuate?
Customer: no power consistent
JA: What is the model of your '80 Ford?
Customer: 2003 F350 7.3 diesel ford
JA: Are you hoping to fix this yourself? What have you tried so far?
Customer: hoping to fix myself all I have done is change fuel filter
JA: Anything else you think the mechanic should know?
Customer: I did change the Idm module no change
Submitted: 2 months ago.
Category: Ford
Expert:  James replied 2 months ago.

HELO, do you get a check engine light on at all?

Customer: replied 2 months ago.
Expert:  James replied 2 months ago.

When you test for codes do you get IDM codes?

Customer: replied 2 months ago.
Customer: replied 2 months ago.
mess with wiring connection at right valve cover was able to drive a short distance with more power but still lacks power and check engine lite stays on disconnect wiring connection at right valve cover no difference as power. did change idm but with no results. used a carmd but the carmd shows no problem code
Customer: replied 2 months ago.
it showed nothing
Customer: replied 2 months ago.
as of yet I have not received a answer
Customer: replied 2 months ago.
I request a refund I have not received an answer to my question
Expert:  James replied 2 months ago.

As much as I would love to I can't live on the internet. I am just waking up for the day. If you would like to continue please let me know.

Expert:  James replied 2 months ago.

Your problem is goin to be under the valve covers. The rough running if not caused y the IDM module itself is defective wiring. Over the years the under valve cover harnesses wiggle loose and get oil in the connections. This causing changes in the resistances that cause the vehicle to run rough. Same goes for the IC sensor. If there is oil in the connection both the connector and ICP sensor need to be changed. You don't just want to change the under valve harnesses on one side I would highly recommend replacing them both to ensure all 8 cylinders are firing correctly.

Customer: replied 2 months ago.
poor website never really got a good answer, its been over 24 hours I would request a refund and cancel my membership
Expert:  James replied 2 months ago.

I just gave you an answer 2 hours ago. There is no instant answer in diagnosing a vehicle I don't have a magic wand. Tat is why I asked if had codes and you give me a simple no as your answer. Then when I do reply while i'm in bed and get upset because you don't have patience. I gave you an answer on how to repair your vehicle so Yes I did give you an accurate answer. I have fixed these vehicles from day one.

Customer: replied 2 months ago.
I request a refund
Customer: replied 2 months ago.
james need to get a different job If he can't handle the pressure

Related Ford Questions