How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Kenny Z. Your Own Question
Kenny Z.
Kenny Z., Ford Senior Master Tech
Category: Ford
Satisfied Customers: 5212
Experience:  Auto Trans, Drivability and Electrical Specialist
Type Your Ford Question Here...
Kenny Z. is online now
A new question is answered every 9 seconds

My f-150 pick-up cuts off about once a week at a stoplight

Customer Question

my f-150 pick-up cuts off about once a week at a stoplight .it has 43lbs running and 40 after it stops. what else could it be.mechanic has tried every test he can think of and checked vacuum lines.
JA: What year is your F-150?
Customer: 1998 4.2 v6
JA: Are you hoping to fix this yourself? What have you tried so far?
Customer: mechanic has plugged into his machine,shows no codes replaced vacuum hoses
JA: Just to clarify, what's the exact code? And have you tried to reset it?
Customer: no code comes up
JA: Anything else you think the mechanic should know?
Customer: after it cuts off it will not start for about 30 seconds (will turn over). after about 30 seconds starts and runs fine for about a week
Submitted: 2 months ago.
Category: Ford
Customer: replied 2 months ago.
Posted by JustAnswer at customer's request) Hello. I would like to request the following Expert Service(s) from you: Live Phone Call. Let me know if you need more information, or send me the service offer(s) so we can proceed.
Expert:  Kenny Z. replied 2 months ago.

Hello, my name is***** and thanks for your question.

Do you ever hear squeaking from the front of the engine similar to a belt noise? Especially before it stalls?

Customer: replied 2 months ago.
no noises
Expert:  Kenny Z. replied 2 months ago.

Ok, the most common issue for stalling with these is the cam sensor and synchronizer assembly. But they usually make squeaking noises when the syncro is failing and also set code P0340. Can't tell you to replace them without more confirmation. When it is in the no start mode for 30 seconds after stalling have you noticed if the check engine light goes out when cranking? If you don't know then next time is happens you want to know if the check engine light illuminates in the run position with the engine off and then goes out while cranking. This will at least show if the PCM is on line during the fault and if it is seeing a crankshaft signal when cranking. This one is not going to be easy being so intermittent and the fault only lasting 30 seconds. You might even swap out the PCM relay, seen them fail in this manner also.