How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Ron Your Own Question
Ron
Ron, ASE Certified Technician
Category: Ford
Satisfied Customers: 23001
Experience:  23 years with Ford specializing in drivability and electrical and AC. Ford certs and ASE Certs
7276279
Type Your Ford Question Here...
Ron is online now
A new question is answered every 9 seconds

I have a 2002 Ford focus wagon. I took it to get a smog and

Customer Question

I have a 2002 Ford focus wagon. I took it to get a smog and the Lean code PO171 came back, they mentioned it was a MAF sensor it could be dirty or need replaced. The car runs well but it does seems at time like it doesn't have full power on big hills. Also My sis got a new alternator about month ago, and I recently a battery. As I was driving the battery light blinked then left, then he came on again when I exited off freeway & then left. I had both tested battery is good, alternator is working but its showing some things going on with communication to battery
Submitted: 4 months ago.
Category: Ford
Expert:  cloe0626 replied 4 months ago.

i would start by checking the battery terminal they may need to be replaced

Customer: replied 4 months ago.
All that's been done
Expert:  cloe0626 replied 4 months ago.

have you traced the cables to make sure there is no exposed wire on the cables

Customer: replied 4 months ago.
on the battery cables were checked when I got battery

Related Ford Questions