How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Chris (aka- Moose) Your Own Question
Chris (aka- Moose)
Chris (aka- Moose), Technician
Category: Ford
Satisfied Customers: 43915
Experience:  16 years experience
Type Your Ford Question Here...
Chris (aka- Moose) is online now
A new question is answered every 9 seconds

I installed a chip. Now my engine light and service advance

Customer Question

I installed a chip. Now my engine light and service advance light is on. It's a 2012 f150 5.0
JA: Do you have the trouble code? Do you have a code reader or scan tool?
Customer: No
JA: Not a problem. You can work with the Ford Mechanic to figure that out. What is the model of your '12 Ford?
Customer: Xlt
JA: Are you hoping to fix this yourself? What have you tried so far?
Customer: Yes I was hoping to do it myself. All I have done is disconnected the battery hoping it reset
JA: Anything else you think the mechanic should know?
Customer: No that's it
JA: OK. Got it. I'm sending you to a secure page on JustAnswer so you can place the $5 fully-refundable deposit now. While you're filling out that form, I'll tell the Ford Mechanic about your situation and then connect you two.
Submitted: 3 months ago.
Category: Ford
Expert:  Chris (aka- Moose) replied 3 months ago.

Welcome, I'm Chris (aka Moose) I prefer working afternoon till just after midnight.

Can you tell me more about this chip, what it does, how it is installed?

Once you did the battery reset, how soon do the lights come back on?

Beside the lights is the vehicle operating any different?

Customer: replied 3 months ago.
It's a pcd performance chip stage 1. It's suppose to increase hp. It's is installed to the IAT. After I unhooked the battery and hooked it back soon as I start it they come on. The service advance track and engine light. It's run different not picking up like it should
Expert:  Chris (aka- Moose) replied 3 months ago.

Thanks, ***** ***** chip is doing is confusing the IAT reading to the computer so the computer will change the air fuel ratio by adding more fuel. The check engine light has come on because this chip is bad or was installed wrong or it has given the computer an IAT reading that it realizes is no way possible. The advance trac warning has possibly come on because the vehicle is getting a wrong IAT and MAF reading so it thinks your applying throttle but your not moving so the computer thinks there is an issue with the ABS wheel speed sensor readings.

My suggestion is to have it scanned at a parts store or shop to see which codes are stored. Then remove the chip and reset the codes to see if they return. This will tell you if the chip is to blame or not for these codes.

If you're confused on what to do now or later. You have already been charged the full question value. It's now time to compensate the tech that helped you. The only way I can continue to work here and help customers is by getting rated. If you're not pleased yet or plan not to rate me. Let me know so I can help more, close the post, or opt out. Please let me know if you're pleased with my help.

Thanks Moose.

Expert:  Chris (aka- Moose) replied 3 months ago.

Hello again Chris here,

  • I am contacting you because the post has not been closed out/completed.
  • It appears you were not pleased with my help.
  • If more assistance is needed, reply and let me know, also let me know what it is you're needing to be pleased.
  • This post is coming up on the 7 day mark where it times out. When a post times out, that means it's no longer on my active list (you reply and I never know it.)
  • You have already paid the fees to get this question answered, and I do not want you to leave having paid for something that did not meet your wants/needs and myself not receiving a feedback selection from yourself.

Thanks Chris