How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Chad Farhat Your Own Question
Chad Farhat
Chad Farhat, ASE Certified Technician A6 - Electrical / Electronic systems A7 Heating / Air conditioning systems
Category: Ford
Satisfied Customers: 1222
Experience:  Owner at Carolina Auto Service & Sales , 20 years experience in Foreign & Domestic Vehicles
Type Your Ford Question Here...
Chad Farhat is online now
A new question is answered every 9 seconds

Engine starts but stops immediately. Yes to both. I worked

Customer Question

Engine starts but stops immediately.
JA: Will the headlights turn on? Is the battery fully charged?
Customer: Yes to both. I worked on engine intake manifold for vacuum leaks and replaced fuel filter and pump. I suspect the vacuum hoses, and there is one hose outlet under the IAC valve which is plugged because I don't know where it goes to.
JA: What is the model/year of your Ford?
Customer: 2001 e 250. 5.4EFI engine.
JA: Are you hoping to fix this yourself? What have you tried so far?
Customer: Yes. No money for a mechanic. I checked for proper function of the pump and eliminated the worst installation of an anti theft device under the steering wheel.
JA: Anything else you think the mechanic should know?
Customer: That is everything I can think of. It will run on starting fluid, so I know I have combustion.
JA: OK. Got it. I'm sending you to a secure page on JustAnswer so you can place the $5 fully-refundable deposit now. While you're filling out that form, I'll tell the Ford Mechanic about your situation and then connect you two.
Submitted: 4 months ago.
Category: Ford
Expert:  Chad Farhat replied 4 months ago.

Hi, I'm Chad. Welcome to JustAnswer. I'm reviewing your question now, and I will post back with your reply ASAP

Expert:  Chad Farhat replied 4 months ago.

i know you said you eliminated the anti theft , please tell me how did you do that

is the security light on now or its is off since you disconected ,and did the no start problem happened after the antitheft disconnected

if you spray starting fluid and runs and ies , mean pump not running, but not running since the ground is missing from the ecm because the antitheft is not available for the ecm to see to authorize start up ,

how this no start happened and do you have ground at that fuel pump when u attempt to start can you check for me ?

let me know please

Thank You ***** ( aka -Customer)

ASE Certified Tech

Customer: replied 4 months ago.
The anti theft device was a kill switch located under the dash installed by the dealer in case I didn't pay. Since I have only one payment to go and a perfect record, they agreed to let me remove it. It had red, green and black wires coming from it. Black was grounded, one went to OBD2 connector and the other came from what I think is the PCM cable.
Customer: replied 4 months ago.
No-start has been happening for two weeks. Anti theft uninstall was today. My last good idea.
Expert:  Chad Farhat replied 4 months ago.

ok let me check few things give few minutes

Expert:  Chad Farhat replied 4 months ago.

how hard is it to scan the ecm module for me and get me those codes

while the no start condition , what are we loosing spark or fuel or we missing both, have you checked

the wire you unhooked that was going to computer how was tied in to it and did u check it did get pulled out ?

let me know please

Customer: replied 4 months ago.
The original codes were p0171 & 0174. Lean mixture on bank 1 & 2. Symptoms were a loud humming noise from the engine compartment, LTFT at 34% and difficulty starting cold. After consulting with mechanic friends, I decided that there was a vacuum leak at the intake manifold and proceeded to replace it. Due to the extent of the repair, I had to disconnect the battery, so there are no codes from the computer.
Customer: replied 4 months ago.
We have spark; the engine runs on anything flammable pumped into the throttle body.
Expert:  Chad Farhat replied 4 months ago.

so we need fuel , fuel pump not running , is it the fuse is out and have no power to pump or is it the ecm or the wiring to it is bad and we are missing a ground , how about checking ground at the fuel pump with key switch to the start position and test light at the fuel pump connector or relay and check for ground

hook your test light lead to the positive side of the battery and anything you touch if it lights up we have found ground

let me know


Customer: replied 4 months ago.
It lights up on the bottom horizontal receiver of the relay.
Expert:  Chad Farhat replied 4 months ago.

does it light up on turn of switch

and where you checking ground or power when it light up

Customer: replied 4 months ago.
I had the ignition turned to on, and then I inserted it into the bottom receptacle. I would assume the bottom is ground, no?
Expert:  Chad Farhat replied 4 months ago.

the ignition switch should be on the start not on position, like somebody turning the switch and hold it in the start position while you test

the bottom is ground of the relay , i m sorry you lost me there, ask me again :)

Customer: replied 4 months ago.
Update from yesterday: I got fuel and pressure to the rail, but it still doesn't stay running. Could timing be the issue? Live data told me that the timing was advanced all the way when I used starting fluid while it was running.
Expert:  Chad Farhat replied 4 months ago.
if timing is off on scanner it will show it
Customer: replied 4 months ago.
How would I fix the timing so the computer doesn't advance it?
Expert:  Chad Farhat replied 4 months ago.

Pull the timing cover off and check the timing this way by looking at timing marks

or if you have a timing test light and know how to check with it , you can do that .

2001 Ford Truck Econoline E250 3/4 Ton V8-5.4L SOHC VIN L
Expert:  Chad Farhat replied 4 months ago.

Parts InformationOEM Part #Price

Timing Cover

15 - Front Cover


Labor InformationSkill LevelMfg. WarrantyStandard

Replace Front Cover

8.8 hrs labor

now this the labor time to replace the chain , but checking it probably 1/2 the time to get to cover & take it off

Expert:  Chad Farhat replied 4 months ago.

Hope I was helpfull to you ,Let me know if you need anything else on it

A Positive rating is Much Aprecciated

This Post Will Stay Open for you to Come Back And Ask Me Any Follow Up Questions You May have On This Issue Even after You Rate Me

Thank You

Chad Farhat ( aka -Customer)
ASE Certified Technician