How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Jeremy Your Own Question
Jeremy
Jeremy, Certified Diesel Technician/Electrician
Category: Ford
Satisfied Customers: 2781
Experience:  ASE, NATEF Engines and Electrical certified, EPA 608/609
9290743
Type Your Ford Question Here...
Jeremy is online now
A new question is answered every 9 seconds

My 2003 Ford Expedition has lately begun flashing 4H and 4L

Customer Question

My 2003 Ford Expedition has lately begun flashing 4H and 4L lights on the dash. It does it 3 times then goes back to normal for days at a time before it flashes them again. I took it to a Ford dealer who ran some diagnostics but couldn't find anything wrong. What to do?
JA: Have you checked the fuses? Have you tested the dashboard light bulbs?
Customer: No. How do I do that?
JA: Are you hoping to fix this yourself? What have you tried so far?
Customer: I went on the Ford forum on the Web and they said it could need a new transfer case.
JA: Anything else you think the mechanic should know?
Customer: No. One blogger said I could remove Fuse #130 under the hood, but I haven't done that because the vehicle runs perfectly except for the occasional flashing lights
JA: OK. Got it. I'm sending you to a secure page on JustAnswer so you can place the $5 fully-refundable deposit now. While you're filling out that form, I'll tell the Ford Mechanic about your situation and then connect you two.
Submitted: 5 months ago.
Category: Ford
Expert:  Jeremy replied 5 months ago.

My name is ***** ***** I will assist you with your question today.

I'm an independent contractor and I don't get paid until a rating has been made.

We can go back and forth as needed to help resolve the issue you are having. Follow ups are free after ratings, so rate in confidence!

It will be one of two sensors on the transmission with it being intermittent. They are both Hall sensors. One is at the rear driveshaft and the other at teh front drive shaft. They cost about $30 each and I suggest changing them out. Most likely it will be the rear one since that is the shaft that spins all the time. You will see it mounted just before the drive shaft.

The only other thing that I have had cause that was the accessory delay relay, but the windows quit working and the radio goes out. You didn't mention that so it will be one of the sensors. Pretty common to be the rear on these.

__________________________________________________________________________________________________________________________

You want a 5 star service and I want to provide a 5 star service. Please consider that I don't know your skill level as well as I can't see, touch, smell, hear the vehicle/machine in question. Please provide as much detail as possible and I will provide as much back.

Once an answer is provided, you should see a rating screen. Please rate my personal service to you. The ratings are my personal feedback,

they are not the site feedback.

Thank you for allowing me to assist you through Just Answer!

Jeremy

Expert:  alma-cssm replied 5 months ago.
Dear Customer,
It appears that you have submitted your question twice and so you were also charged twice. We want to correspond with you so we can assist you in fixing this but we do not have your email address. Please contact customer support at***@******.*** and provide us with your email address and a link to this question page so that we can help you. (http://www.justanswer.com/ford/9rjje-2003-ford-expedition-lately-begun-flashing-4h-4l.html). Thank you, ***** ***** Customer Support Team.
Expert:  Jeremy replied 5 months ago.

Do you still need assistance with this?

Expert:  Jeremy replied 5 months ago.

I see you viewed this and this is still showing as an open question due to no positive (3 stars or more) rating.

Were you not pleased with my service to you or is there a rating issue? Please let me know if you still need assistance with this, if there is a rating issue, and/or you need more time to respond.

I like to make sure all my customers are satisfied since you did pay a deposit for me to assist you, whether I’m paid by a positive rating feedback or not.

We can continue where we left off or start over if needed. Also, if you need diagrams, instructions, etc please don’t hesitate to ask.

Related Ford Questions