How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask roy Your Own Question
roy
roy, import/domestic specialest
Category: Ford
Satisfied Customers: 4656
Experience:  ASE master tech for 40 years
3506196
Type Your Ford Question Here...
roy is online now
A new question is answered every 9 seconds

Ron i have 1989 ford class c motorhome with a 460 efi. this

Customer Question

Hi Ron
i have 1989 ford class c motorhome with a 460 efi. this is a couple months new to me. here are the things that i replaced just to be as reliable as possible. MAF, Fuel/idle air mixture, both fuel pumps, egr, there is something in the middle of the fuel lines that allows the fuel to go back into the tank(can remember what it is called) looks like a fuel filter but its not, fuel filter alternator. anyways the problem that i have is after driving on freeways or in town if i come to a stop it dies, it starts right back up. if i keep my foot on the throttle a little it stays running, i have thought about adjusting the peddle to to keep (thinking that maybe the cable stretched over the years) but i dont think that is the right fix any ideas? im at work so not currently looking at it. thanks
Submitted: 5 months ago.
Category: Ford
Expert:  roy replied 5 months ago.

good afternoon my name is ***** ***** I will assist

it sounds like a throttle body issue. there is a solenoid on the top called an idle air solenoid. did you replace that???

Roy

Customer: replied 5 months ago.
Not sure Roy I looked it up online to see the pic, is it located right under the air intake of the throttle body? Because that one I did I thought that was the idle air mixture one
Expert:  roy replied 5 months ago.

ok, it has a connector and 2 attaching bolts???

if that is it. check for voltage at the connector with the key on???

Roy

Customer: replied 5 months ago.
Ok I'll check when I get home what should it be at?
Customer: replied 5 months ago.
I'm assuming 12 volts
Expert:  roy replied 5 months ago.

yes, that is correct

Expert:  roy replied 5 months ago.

how are you making out

Expert:  roy replied 5 months ago.

please dont forget to rate me as it is the only way I get paid for my efforts

Roy

Expert:  roy replied 5 months ago.

please dont forget to rate me as it is the only way I get paid for my efforts

Roy

Expert:  roy replied 5 months ago.

please dont forget to rate me as it is the only way I get paid for my efforts

Roy