How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Matt Your Own Question
Matt
Matt, Engineer
Category: Ford
Satisfied Customers: 20604
Experience:  BEng hons Mech engineering, in auto industry 22 years
12772297
Type Your Ford Question Here...
Matt is online now
A new question is answered every 9 seconds

1993 Bronco 5.8. Looses power and throttle response when the

Customer Question

1993 Bronco 5.8. Looses power and throttle response when the stereo is turned on. Alt guage goes from m to between O and r and she becomes gutless. Put new alt 95 amp, still same.
Submitted: 6 months ago.
Category: Ford
Expert:  Matt replied 6 months ago.

Hello

for the truck to lose power when you switch on the radio would mean that the radio is short circuited and probably with the wiring harness to the ECU / PCM unit

I'd suggest pulling the radio out from the dash and checking over its loom for heat damage / broken insulation and other signs of short circuit

Expert:  Matt replied 6 months ago.

Hi

do you still need help?

Bear in mind that the site takes a deposit from you at the beginning and this is held by the site until you rate my answer at which point the cash is split between the site and the expert. I am only paid for my work on this question if you rate my answer, using the star system at the top of the screen. Please do not forget! Thank you

Customer: replied 6 months ago.
It isn't always when the radio is on the last few times we were heading thru the mountains and when I needed a little more pedal it wasnt there. In fact if I push to the floor throtle response, when this happens, is nil. I just replaced the tps and that didnt seem to help. It has a new alternator in it and an 1000 cca industrial battery. I am still stumped at the flucuation from running decent to falling on its face.
Expert:  Matt replied 6 months ago.

Hello

OK if its possibly not the radio then I'd start in the engine bay

This could be a wiring issue as things tend to expand when hot and its possible a poor or partial electrical connection is being pushed apart on one of the major sensors so check the connection plug and wiring to the following;

Airflow meter

Crank position sensor

Cam position sensor

O2 sensor

Throttle position sensor

unplug each in turn and use some switch / contact cleaner spray on the pins to ensure its all grease / dirt free

Also worth checking the connections to the fuel pump for the same reason - unplug each in turn and give them a good squirt of switch / contact cleaner - Not WD40

and also unplug and inspect the main power relays and fuses for signs of overheating or corroded terminals - so the ones for the ECU and the fuel pump

And also unplug the wiring loom connections in the engine bay one at time and inspect for corroded or recessed pins.

Check the resistance of the spark plug leads ( 13-15Kohm / metre) and replace if any doubt or high resistance - Also replace the spark plugs if any of them fail this checklist:

http://www.ngksparkplugs.com/tech_support/spark_plugs/faqs/faqread.asp

Also its worth checking that the electric pump that feeds the injectors is working correctly, it should run for a few seconds then switch off when you first turn the ignition on. If the connections to this are corroded or damaged then the pump could stop at any time. Check that its relay switches in and out and the relay contacts are clean and bright – replace the relay if in any doubt and do the same for the fuse, ideally measure the voltage at the pump and check its getting 12V

Expert:  Matt replied 5 months ago.

Hi

do you still need help?

Bear in mind that the site takes a deposit from you at the beginning and this is held by the site until you rate my answer at which point the cash is split between the site and the expert. I am only paid for my work on this question if you rate my answer, using the star system at the top of the screen. Please do not forget! Thank you

Related Ford Questions