How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask HDGENE Your Own Question
HDGENE
HDGENE, Ford Senior Master/Diesel/Trans
Category: Ford
Satisfied Customers: 4784
Experience:  25 years Auto experience, Ford ,GM, Chrysler, Asian & European
285738
Type Your Ford Question Here...
HDGENE is online now
A new question is answered every 9 seconds

I have a 2008 ford powerstroke 6.4 liter. It has a black

Customer Question

I have a 2008 ford powerstroke 6.4 liter. It has a black maxx tuner. Periodically the truck won't build boost. I have had two different codes. One say map sensor and other is turbo not detected. I changed oil and replaced all filters. Have after market K&N air filter and cleaned as well. Truck ran good. Then started messing up, not building boost. Removed the EBP sensor hose and cleaned with a small wire. Again the truck ran alot better. Now it's gapping again. What could be the cause?
Submitted: 6 months ago.
Category: Ford
Expert:  HDGENE replied 6 months ago.

Hello, have you tried reverting the tuner back to the stock programming and see if you still have the same concern? Sometimes a tuner program can become corrupt and need to be reinstalled. To verify if its not a turbo or map sensor issue this would be the first thing to try

Expert:  HDGENE replied 5 months ago.

Hello, do you need more help or information?

Customer: replied 5 months ago.
I have taken the boot off the air intake that connects to the turbo. The turbon spins free and has very little if any play up and down, no play back and forth.
Expert:  HDGENE replied 5 months ago.

Ok but that wont completely tel if there is a turbo issue or not. It spins at thousands of rpms when commanded. Need to revert to stock programming first as I mentioned and see if it resets the codes.

Customer: replied 5 months ago.
There is a boot that comes off my intercooler connects to another blue after market pipe. The boot Is about 2 inches wide and seemed to have a slow leak maybe. When I ran my hand down the Gray pipe there was a bunch of black crud on the bottom side of the pipe. I was wondering if an air leak could cause the loss of power?
Customer: replied 5 months ago.
How do I turn my tuner into stock mode? I can unplug it but it is still programed to the computer in the truck.
Expert:  HDGENE replied 5 months ago.

If those boots blown off it would cause a major loss of power. The tuners are all different how they work,with it plugged in, there should be an option to revert to stock programming.Not unusal to see a little soot.If it is leaking it needs to be repaired.

Customer: replied 5 months ago.
My truck isn't throwing any codes today and have already erased the codes the other day. There is an EBP sensor that has a brass tube that screws to the intake. I have read that the tube can get clogged and cause the power loss. Do you agree? I have ordered the new sensor and tube also a new map sensor. Gonna try these things g's before I go spending get 3k on a new turbo. Think this could be the issue at hand?
Expert:  HDGENE replied 5 months ago.

Yes that is a possibility and can be verified by removing the sensor from the tube and running the engine and checking for flow out of the tube.

Customer: replied 5 months ago.
How commonly do the veins on a 6.4 get clogged up? Is this a common thing. The truck only has 80k miles.
Customer: replied 5 months ago.
By taking the tube from the sensor or off the intake? Sorry didn't understand.
Customer: replied 5 months ago.
What exactly does the map sensor and EBT senor do?
Customer: replied 5 months ago.
Do they controll boost?
Expert:  HDGENE replied 5 months ago.

By removing the sensor from the end of the tube to see if it is clogged. Clogging of the veins is possible but not as bad as the 6.0 turbo. Map sensor measures engine load and EB measures exhaust back pressure so yes they have an impact on turbo operation

Customer: replied 5 months ago.
The tuner I have is a black maxx hd300 it's an older one. Every time I have ever tried to mess with it other than turning it up and down has through the truck into limp mode. The lowest setting says stock or no power. And yes it still has the same issue when it's on the lowest setting.
Expert:  HDGENE replied 5 months ago.

Then you need to addres the possible map sensor issue or clogged ebp as youmentioned.Need to be able to look at live sensor data to see if the sensors are biased/giving an incorrect reading.

Customer: replied 5 months ago.
I would think if the turbo was clogged and the veins were getting stuck, they would either stick on or stick off. Engaged or not. It wouldn't keep coming in and out?
Expert:  HDGENE replied 5 months ago.

Follow the code, these turbos dont have much clogging issues.

Customer: replied 5 months ago.
That's kinda what I've gathered. But the no turbo detected and a diesel mechanic saying the turbo was the problem after putting on live data scared me. I've just been reading a lot on the Web and everyone says the same thing. Sorry for the long text.
Expert:  HDGENE replied 5 months ago.

No problem, the twin turbos have issues, but it depends on what type of code is being stored. Need to look at the basic stuff first before replacing one.

Customer: replied 5 months ago.
One other thing. I've heard the where the down pipe hooks the manifold the bolts come loose on the 6.4s. Could this be the issue for the power loss as well?
Expert:  HDGENE replied 5 months ago.

If that was the case you would hear a leak.

Customer: replied 5 months ago.
What would it sound like? When I'm in park and I rev the engine up, it makes a sort of grinding noise at 2k rpm's. The first couple times it was kind of a squeal sound.
Expert:  HDGENE replied 5 months ago.

A whistle or loud exhaust leak

Customer: replied 5 months ago.
Whoever built the truck put all kinds of money into it. It's been bullet proofed, black maxx tuner, 7 inch lift with 20in motto metal rims, 37in super swamppers, egr and dpf deletes. To many extras to count. I just hope this isn't a major problem. Lol
Customer: replied 5 months ago.
No I don't hear that...
Expert:  HDGENE replied 5 months ago.

Just stick with the basic stuff to check first,rule out any issues with the ebp and tube and go from there

Customer: replied 5 months ago.
Can you think of any other sensors that could be going bad or throwing these codes? Other than checking the ones mentioned and checking all boots and hose connections?
Customer: replied 5 months ago.
That's where I will start and what I was going to do. Can I get ahold of you after the parts arrive or do I have to pay the fee again?
Expert:  HDGENE replied 5 months ago.

CHeck those first, and yes you can follow up on this question and no you dont have to pay again long as you keep on this question topic.

Customer: replied 5 months ago.
Heck yeah brother, I appreciate your time. And will let you know what I find and will go from there. Thanks a lot man...
Expert:  HDGENE replied 5 months ago.

No problem, just let me know if you need more help with this, easy to get deep into a problem and overlook things. If I was helpful please leave a positive rating. We can still go back and forth if you need more help with this

Customer: replied 5 months ago.
I will just want to leave this up cause I feel like I'm going to need to go back and forth for awhile... lol
Expert:  HDGENE replied 5 months ago.

No problem.

Related Ford Questions