How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Ron Your Own Question
Ron, ASE Certified Technician
Category: Ford
Satisfied Customers: 23001
Experience:  23 years with Ford specializing in drivability and electrical and AC. Ford certs and ASE Certs
Type Your Ford Question Here...
Ron is online now
A new question is answered every 9 seconds

Ranger XLT 2.3l auto: ***** ***** XLT 2.3l Auto; have replaced

Customer Question

1998 Ranger XLT 2.3l Auto; have replaced thermostat, Temp Sensor, and Temp sender. Truck still will not warm up; guage shows "warm" or normal when engine is off, drops to below Cold when started, and then never gets above "Cold" on the gauge. Top hose warms up after running for a while, and some heat comes from the core, but that's it. If I let her idle for awhile after running, Gauge will move up beyond "Cold" on the gauge, but not much.
Any ideas/suggestions?
Submitted: 5 months ago.
Category: Ford
Expert:  AMEDEE replied 5 months ago.
Hello and welcome! My name isCustomerand I can assist you with your question. Have you checked the engine tempature using a external temp gauge or electronic tempature gun?
Customer: replied 5 months ago.
No, since the hose and heater core temp stay low as well...
Expert:  AMEDEE replied 5 months ago.
Ok, then this will be your next step.