How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Pete Your Own Question
Pete
Pete, Auto Service Technician
Category: Ford
Satisfied Customers: 24656
Experience:  Over 17 years diagnosing and repairing automobiles various makes and models with some training and certifications.
14928985
Type Your Ford Question Here...
Pete is online now
A new question is answered every 9 seconds

I am not getting fuel to an 08 F250. Both pumps run when 12V

Customer Question

I am not getting fuel to an 08 F250. Both pumps run when 12V are place on them. Fuses are good. Throttle body whines constant with the key on. I would like to continue reading this article.
JA: Sometimes boat issues seem like they'll be really complicated, but end up being easy to fix. The Marine Mechanic I'm going to connect you with knows all the tricks and shortcuts. Tell me a bit more about what's going on so the Marine Mechanic can help you best.
Customer: Engine was running 100% fine. I changed water pump, thermostats and 10 micron filter. Pulled away from the dock and it nocked (not tapped) and died. I tried both tanks, both are full of fresh fuel from a very busy gas station. I rechecked the fit of the gasket on both filters. The build pumps up normally and is firm. I suspect something very stupid is happening
JA: Is there anything else important you think the Marine Mechanic should know?
Customer: That's my story.
JA: OK. Got it. I'm sending you to a secure page on JustAnswer so you can place the $5 fully-refundable deposit now. While you're filling out that form, I'll tell the Marine Mechanic about your situation and then connect you two.
Submitted: 7 months ago.
Category: Ford
Expert:  Pete replied 7 months ago.
Hi my name is ***** ***** I will be happy to assist with this today.In some cases I may need more info to assist better.I apologize for any delay. Have you had the fault codes checked at all to see what codes are set with this issue here? Let me know so we can continue,thanks Pete.
Customer: replied 7 months ago.
I have not checked the codes. It will take 4 weeks to get a shop to look at it in May. I am not getting any codes on the gauges.
Expert:  Pete replied 7 months ago.
What liter engine is in your model here? Are the fuel pumps not receiving voltage at all?
Customer: replied 7 months ago.
It is the 3.3. Not sure if they are getting voltage. I ran 12V across them and they activated. Perhaps I should drain the VST and see if the float activates the HP pump ...?
Expert:  Pete replied 7 months ago.
If you can drain this I would see if this then allows them to work.If there is air in the drain or system you may have a leak where the high pressure pump is sucking in air and fuel and can cause this here and would need to be checked over,located and repaired.If no leaks are found and if this does not work let me know. If more help is needed, use the reply tab to continue our conversation. If no further assistance is needed, kindly rate my service.You can rate at any time and we can continue to work on your question as this will not close out your question.Keep in mind in some cases it can be difficult to fully diagnose or help repair your vehicle without seeing it and I work on delivering the best possible answer from what I see to work with.Thanks Pete