How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Ray M. Your Own Question
Ray M.
Ray M., Ford Master Tech
Category: Ford
Satisfied Customers: 3019
Experience:  30+ years in trade, Ford Master Tech, Journeyman Automotive Tech
11409661
Type Your Ford Question Here...
Ray M. is online now
A new question is answered every 9 seconds

I have 2005 ford F350 we done the heads on it and now the speedometer

Customer Question

i have 2005 ford F350 we done the heads on it and now the speedometer is not working what could it be
JA: Sometimes things that you think will be really complicated end up being easy to fix with a Ford. The Ford Mechanic I'm going to connect you with knows all the tricks and shortcuts. Tell me a bit more about what's going on so he can help you best.
Customer: it was working fine before we took it apart. and we took the cab and the doghouse off of it and the speedometer and odometer was working fine. and now it isn't working at all. and we checked all the fuses and everything checked out fine.
JA: Are you hoping to fix this yourself?
Customer: yes
JA: Great! What have you tried so far?
Customer: We checked all the fuses that it could be and we checked all the plugs.
JA: Is there anything else important you think the Ford Mechanic should know about your Ford?
Customer: no
JA: OK. Got it. I'm sending you to a secure page on JustAnswer so you can place the $5 fully-refundable deposit now. While you're filling out that form, I'll tell the Ford Mechanic about your situation and then connect you two.
Submitted: 7 months ago.
Category: Ford
Expert:  Ray M. replied 7 months ago.
when heads were done was the cab taken off?
Customer: replied 7 months ago.
Yes it was
Customer: replied 7 months ago.
Yes the cab and doghouse both were taken off of the truck at the same time
Expert:  Ray M. replied 7 months ago.
Okay, the problem is likely in one of the connectors on the drivers side inner fender liner not being plugged all the way in. You need to access them and unplug each one, one at a time, then spray some WD40 into the connector and blow it out. Quite often they get dirt and dust in them and this makes them hard to seat all the way. I will be away for a short time, but will be back later today if you need more help. Thanks.
Expert:  Ray M. replied 7 months ago.
I am back now.