How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Chris (aka- Moose) Your Own Question
Chris (aka- Moose)
Chris (aka- Moose), Technician
Category: Ford
Satisfied Customers: 44516
Experience:  16 years experience
2499435
Type Your Ford Question Here...
Chris (aka- Moose) is online now
A new question is answered every 9 seconds

2009 Mustang GT: , I am having issues with my 2009 Ford

Customer Question

Hello, I am having issues with my 2009 Ford mustang gt. When I started it yesterday, the wrench light, check engibe light and battery light came on. Cluster is reading fuel level low, dte odo error, check charging system. Battery and alternator tested good. Vehicle is running perfectly fine? Any ideas before I spend a bunch at the shop?
Submitted: 7 months ago.
Category: Ford
Expert:  Chris (aka- Moose) replied 7 months ago.
Welcome, I'm Chris (aka Moose). I normally log in after 3 pm central. Please make sure to let me know exactly what is needed from me so I can provide EXCELLENT 5 STAR service. Normally this ends up being a failure of the instrument cluster. If you can confirm there are no trouble codes stored with a scan then i can get you the test to confirm the cluster replacement is needed. -------------------------------------------------------------------------------------On your screen at the top you should see a rating 1-5 stars and a green submit button. Please make sure to select one and press submit. I am not compensated by the website unless a customer rates. Rating only pays me from the deposit you have already made, it does not charge you more, nor close the post. Also all follow ups are free and welcome.Thanks Chris
Customer: replied 7 months ago.
Well several different places have tried to run a scan and aren't able to get it to read. Just get error. Forgot to mention the AC is not blowing cold anymore either. Just the fan blowing room temperature air
Expert:  Chris (aka- Moose) replied 7 months ago.
Are they getting an error trying to scan all modules or just an error trying to read the instrument cluster?
Customer: replied 7 months ago.
Well they plug the scanner in under the dash and it just says bad connection or error, ect. Tried several different places
Expert:  Chris (aka- Moose) replied 7 months ago.
I have the directions for DLC data link connector diag as well for no communication. Would you like those steps from Ford?
Customer: replied 7 months ago.
Sure
Expert:  Chris (aka- Moose) replied 7 months ago.
See the link below.https://dl.dropboxusercontent.com/u/90220402/testC.pdf
Customer: replied 7 months ago.
What is the test to determine if the cluster is bad, forgot to mention that the speedo, tach and several other gauges are not working as well as the other issues? Also are you aware of any places that refurbish them? I know with my GMC pickup i was able to pull it and send it to a place the rebuilt it
Expert:  Chris (aka- Moose) replied 7 months ago.
We have to get the DLC working prior to diagnosing the cluster.Being a dealer tech we are only allowed to use new or refurbished parts from Ford so I do not know of or have experience with clusters aftermarket.
Expert:  Chris (aka- Moose) replied 7 months ago.
Hello again Chris here,1) When customers come to Just Answer the website and the experts want them to have a great 5 star experience.2) We also want them to be so pleased that they come back for future needs.3) I have the feeling you were not pleased with my help because the post was not rated and or you need me to help more. If so please do reply.4) I have an option for an additional fee to upload diagrams, repair guides, find a repair facility, or call you if that would help. Thanks Chris