How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Gary Your Own Question
Gary
Gary, Technician
Category: Ford
Satisfied Customers: 16514
Experience:  GM master tech for 15 years/ASE master tech for 20 years
19513769
Type Your Ford Question Here...
Gary is online now
A new question is answered every 9 seconds

Escape: , I have a 2010 Escape 2.5 cyl 2 misfire i switched

Customer Question

Hello, I have a 2010 Escape 2.5 cyl 2 misfire i switched coils, new spark plugs switched injectors to different cylinders and checked injector wires with noid light checked compresion 185 psi still has dead misfire
Submitted: 1 year ago.
Category: Ford
Expert:  Gary replied 1 year ago.
do you have confirmed spark out of the # ***** coil ?confirmed injector pulse to the # ***** injector ?
Customer: replied 1 year ago.
I do have good spark.
Expert:  Gary replied 1 year ago.
injector pulse ?
Customer: replied 1 year ago.
Yes injector pulse also
Expert:  Gary replied 1 year ago.
so you have spark and fuel and confirmed spark and an injector pulse and you swapped injectors and the compression is goo ?is that correct ?
Customer: replied 1 year ago.
That's correct
Customer: replied 1 year ago.
Tomorrow I was going to check fuel pressure. But I can't understand why it would only pick in cyl 2.
Expert:  Gary replied 1 year ago.
at this point you are down to one of 2 thingsfirst can i ask is # ***** a dead skip at idle ?
Expert:  Gary replied 1 year ago.
its not fuel pressure if it was it would be effecting all the cylinders
Customer: replied 1 year ago.
I agree! I shook the wire harness from the coils and injectors to see If any change but nothing.
Expert:  Gary replied 1 year ago.
if you have a pulse and spark the harness is not the issueis # ***** dead at idle ?
Customer: replied 1 year ago.
Yes
Expert:  Gary replied 1 year ago.
ok at this point this issue has to ba a valve train issue with the # ***** cylinders valves not opening which would still show good compression but the cylinder will not fire OR the crank sensor is firing # ***** cylinder at the correct time causing this issuepull the valve cover and crank it over and see if # ***** valves are visually opening and closing like the other cylinders if not fix the valve train issueif it looks fine then change the crank sensorif you have any questions please ask as i do not get credit for my work until you rate me here at Justanswer
Customer: replied 1 year ago.
I replaced the crank sensor sorry I fail to mention that. I will let you know on what I found
Expert:  Gary replied 1 year ago.
ok sounds goodif you have any questions please ask as i do not get credit for my work until you rate me here at Justanswer