How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Lou P. Your Own Question
Lou P.
Lou P., ASE Certified Technician
Category: Ford
Satisfied Customers: 3721
Experience:  Have been working on Ford GM and Chrysler for 15+ years and ASE master certified.
27644750
Type Your Ford Question Here...
Lou P. is online now
A new question is answered every 9 seconds

Windstar: I have an 03 Ford Windstar minivan. It problem is

Customer Question

I have an 03 Ford Windstar minivan. It problem is a continuously breaking front engine mount. It seems to go through about one a month. I just replaced it again and this time it only lasted two weeks. It fails at a (manufacturers) weld every time. So far I've replaced it five times. I replaced the rear mount a couple of months ago just as a precaution and the mount on the transmission seems to be okay. This van is a taxi so it gets driven fairly hard but there must be more to it than that. Do you know what may be going on here ???

Submitted: 7 months ago.
Category: Ford
Expert:  Lou P. replied 7 months ago.
Hello. Usually when you have a mount that keeps getting broken is because it is the only one that is doing all the work. You need to rev the engine in drive and reverse and see how much the engine moves each way. Most likely it's the transmission mount that is bad that is causing the other mount to break. Let me know your thoughts. Lou.

Related Ford Questions