How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask EricFromCT Your Own Question
EricFromCT, Ford Technician
Category: Ford
Satisfied Customers: 3324
Experience:  20 years dealership exp., ASE A1-A9 L1 L2, Ford Lincoln Mercury Senior Master, Diesel Certified
Type Your Ford Question Here...
EricFromCT is online now
A new question is answered every 9 seconds

05 FORD EXPLORER 4CYL: my adv track light went on started to

Customer Question

my adv track light went on started to lose power,got it home now wont start. is this an expensive fix
Submitted: 6 months ago.
Category: Ford
Expert:  EricFromCT replied 6 months ago.
Hi. It sounds like your battery is dead again. You may have a failed alternator and the new battery has not been charging.
Expert:  EricFromCT replied 6 months ago.
Have you checked out the battery? and/or alternator?
Expert:  EricFromCT replied 6 months ago.
I see you viewed my response on 4/3/2016 at 1:15:37 PM 6 day(s) ago. If you have any more questions on this then please ask me. Otherwise if you would like to close out this chat, then please rate my service and have a great day!
Customer: replied 6 months ago.
Eric it was my alternator,thank you