How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Ron Your Own Question
Ron, ASE Certified Technician
Category: Ford
Satisfied Customers: 23001
Experience:  23 years with Ford specializing in drivability and electrical and AC. Ford certs and ASE Certs
Type Your Ford Question Here...
Ron is online now
A new question is answered every 9 seconds

I have a 1989 f150, 5.8l, 3spd auto. Starts and runs fine,

Customer Question

I have a 1989 f150, 5.8l, 3spd auto. Starts and runs fine, problem is when decelerating, idle does not drop at all. sometimes when I tap the gas pedal it will drop down to proper rpm. Have replaced the tps, iac, checked for vacuum leaks, replaced the tb gasket, and checked for intake leaks. all is good. could the problem be with the eca?
JA: Good to know. The mechanics have tons of experience dealing with this sort of thing. How old is your transmission?
Customer: original to the vehicle, the vacuum modulator is holding vacuum on the trans. Vehicle has 142000 km (90000 miles)
JA: Ok. We'll get you to one of the go-to transmission guys. Other than the problems you mentioned, how has the car been running?
Customer: Runs perfect, maintenance has been kept up
JA: Noted. I'll pass this info along to the mechanic so that he can get you a quick fix. Anything else I can tell the Ford Mechanic before I connect you two?
Customer: Has brand new distributor, ign module, coil, plugs, and wires. coolant temp sensor was replaced, as was thermostat, and coolant temp sender.
JA: Got it. Let's get this figured out. I'm sending you to a secure page on JustAnswer so you can place the $5 fully refundable deposit now. While you're filling out that form, I'll tell the Ford Mechanic about your situation and connect you two. You'll be on the road in no time.
Submitted: 6 months ago.
Category: Ford
Expert:  roy replied 6 months ago.
good morning my name is ***** ***** I will assist have you tried cleaning the plate in the throttle body??? it may be sticking from carbon build up. also, if this has a cable, is it free and not binding??? Roy
Customer: replied 6 months ago.
throttle plate is clean, cable not binding
Customer: replied 6 months ago.
if I disconnect the iac, everything works perfect. that leads me to suspect the eca
Expert:  roy replied 6 months ago.
that is correct. if you have a voltmeter, check the voltage at the iac while running. can you test that for me?? Roy