How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Chris (aka- Moose) Your Own Question
Chris (aka- Moose)
Chris (aka- Moose), Technician
Category: Ford
Satisfied Customers: 43972
Experience:  16 years experience
Type Your Ford Question Here...
Chris (aka- Moose) is online now
A new question is answered every 9 seconds

My 2007 Ford Expedition EL is totally disabled with only the

Customer Question

My 2007 Ford Expedition EL is totally disabled with only the four-way flashers slowly pulsing and the red security lock-out indicator on the dash flashing in time with them. What happened and how do I fix it?
JA: Thanks. Can you give me any more details about your issue?
Customer: I wish there were more details. I came out this afternoon to start the vehicle and the lights were flashing, the doors were unlocked, and the security indicator light on the dash was flashing. I don't know what happened or why the anti-theft system was activated.
JA: OK got it. Last thing — Ford Mechanics generally expect a deposit of about $28 to help with your type of question (you only pay if satisfied). Now I'm going to take you to a page to place a secure deposit with JustAnswer. Don't worry, this chat is saved. After that, we will finish helping you.
Submitted: 7 months ago.
Category: Ford
Expert:  Chris (aka- Moose) replied 7 months ago.

Welcome, I'm Chris (aka Moose). I normally log in after 3 pm central. Please make sure to let me know exactly what is needed from me so I can provide EXCELLENT 5 STAR service.

  1. Turn on the headlights, are they bright and remain bright while trying to start?
  2. Will the engine at least crank or start?
  3. With the key on, what is the theft light doing?
Customer: replied 7 months ago.
Nothing worked except the four ways (which have now quit) and the red anti-theft light
Expert:  Chris (aka- Moose) replied 7 months ago.

Thanks, ***** ***** headlights will not work and the hazards have now stopped it is likely a dead battery. If you have a volt meter you can check it. A good battery has 12.6 volts. Can you try a jump start?


On your screen you should see a rating 1-5 stars. Please make sure to select one. I am not compensated by the website unless a customer rates. Rating only pays me from the deposit you have already made, it does not charge you more, nor close the post. Also all follow ups are free and welcome.

Thanks Chris

Expert:  Chris (aka- Moose) replied 6 months ago.

Hello again Chris here,

1) When customers come to Just Answer the website and the experts want them to have a great 5 star experience.

2) We also want them to be so pleased that they come back for future needs.

3) I have the feeling you were not pleased with my help and or need me to help more. If so please do reply.

4) I have an option to upload diagrams, repair guides, find a repair facility, or call you if that would help.

Thanks Chris