How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Chris (aka- Moose) Your Own Question
Chris (aka- Moose)
Chris (aka- Moose), Technician
Category: Ford
Satisfied Customers: 46060
Experience:  16 years experience
2499435
Type Your Ford Question Here...
Chris (aka- Moose) is online now
A new question is answered every 9 seconds

I have a 2003 ford escape xlt 3.0 6 cy.I changed the plugs

Customer Question

I have a 2003 ford escape xlt 3.0 6 cy.I changed the plugs and all the starter coils and put new gaskets on due to oil leaking around the plugs.The problem is my suv wont start,i am getting gas and spark but nothing.Machine was attached to the computer and it said bad mass air flow switch.Had that changed and still wont start.Any ideas?
Submitted: 1 year ago.
Category: Ford
Expert:  Scott W. replied 1 year ago.

Hello my name is ***** ***** was the code?

Expert:  Scott W. replied 1 year ago.

Is the theft light flashing rapidly when trying to start?

Expert:  Scott W. replied 1 year ago.

Let me know, thanks Scott

Customer: replied 1 year ago.
I don't know what the code was a friend of mine was doing it and he told me the mass flow senser was bad. The theft was was only on before I started it.
Customer: replied 1 year ago.
what happen??
Expert:  Scott W. replied 1 year ago.

Does the theft light flash rapidly, or does it go off?

Customer: replied 1 year ago.
Before I try and start the engine it blinks rapid when I try to start it it goes off
Expert:  Scott W. replied 1 year ago.

Ok if it is blinking rapidly, the PATS system is keeping the engine from starting because it thinks a theft is taking place. Does the instrument cluster power up ok, light come on, check engine ect?

Customer: replied 1 year ago.
when I go to start it all of the lights go off except the battery
Expert:  Scott W. replied 1 year ago.

Is the battery charged up ok? Have you tried jump starting it?

Customer: replied 1 year ago.
I have tried to jump start it and it wants to almost start but wont
Expert:  Scott W. replied 1 year ago.

Have you tried holding the accelerator to the floor while cranking to clear the engine of excess fuel?

Customer: replied 1 year ago.
I have
Expert:  Scott W. replied 1 year ago.

Have you pulled the plugs to see if they are wet with fuel?

Customer: replied 1 year ago.
no
Expert:  Scott W. replied 1 year ago.

I suspect the engine is flooded, I would remove the front 3 plugs and inpsect for wetness, dry them out and reinstall and floor the accel pedal while cranking and it should start.

Customer: replied 1 year ago.
wouldn't I have smelled the gas
Expert:  Scott W. replied 1 year ago.

Sometimes you can smell the fuel sometimes you can't, if you remove the plugs and they are wet then you will know for sure.

Customer: replied 1 year ago.
ok I will try that ,but what if they are not wet
Expert:  Scott W. replied 1 year ago.

Then we will look elsewhere.

Customer: replied 1 year ago.
that's it? and if they are not wet then I have to come back on here tomorrow wow
Expert:  Scott W. replied 1 year ago.

Unless you want to pull them out now? I'm still here....

Customer: replied 1 year ago.
I am at work right now and my car is home
Expert:  Scott W. replied 1 year ago.

Well then I don't understand what you want me to do, this question remains open as long as you want, I am trying to help with diagnosis, but we don't know for sure if the plugs are fouled, fuel pressure is good, or too high. We just need to eliminate some things first.

Customer: replied 1 year ago.
ok I though you might of had something else to check if that wasn't the problem.If that ends up being the problem fine but if it isn't I guess I have to keep coming up on line
Expert:  Chris (aka- Moose) replied 1 year ago.

Welcome, I'm Chris (aka Moose). Experts aren't employees / agents of Just Answer. We are independent service providers using the Site to sell their Expert knowledge to Customers. I strive to provide EXCELLENT 5 STAR service, let me know what's needed from me so your pleased.

  1. The previous tech has opted out,
  2. Would you like me to help?
Expert:  Chris (aka- Moose) replied 1 year ago.

Hello again Chris here,

1) When customers come to Just Answer the website and the experts want them to have a great 5 star experience.

2) We also want them to be so pleased that they come back for future needs.

3) I have the feeling you were not pleased with my help and or need me to help more. If so please do reply.

4) I have an option to upload diagrams, repair guides, find a repair facility, or call you if that would help.

Thanks Chris