How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Pete Your Own Question
Pete
Pete, Auto Service Technician
Category: Ford
Satisfied Customers: 24656
Experience:  Over 17 years diagnosing and repairing automobiles various makes and models with some training and certifications.
14928985
Type Your Ford Question Here...
Pete is online now
A new question is answered every 9 seconds

I had the same isue where I am using after market mirrors. I

Customer Question

HI I had the same isue where I am using after market mirrors. I also received a check engine light. I went ahead and purchased an ambient sensor and pigtail. I plugged in wires to the 2 available pins. I read 74 f. I then switched the wires to make sure it was the correct position. Temp dropped back to 50 f. Now it's stuck there. Did I mess up the sensor?
Submitted: 9 months ago.
Category: Ford
Expert:  Pete replied 9 months ago.

Hi my name is ***** ***** I will be happy to assist with this today.In some cases I may need more info to assist better.I apologize for any delay.

Try plugging it in the correct way that read the correct temp where you are located and then operate the vehicle for about 10 miles and see if the temp signal then updates.On some models you have to drive it for it to update and read correctly again.If this does not work I doubt the sensor itself was damaged but what can occur in some cases is one or more codes may set in the computer which may be causing this reading to skew like this here.You may have to have a scan tool plugged into your vehicle to clear out any codes set and then from there it should operate.I dont see anything that would have been damaged when this was done.Most likely just a drive to reset it will work or clearing out any fault codes set will work in most cases.

If more help is needed, use the reply tab to continue our conversation. If no further assistance is needed, kindly rate my service.You can rate at any time and we can continue to work on your question as this will not close out your question.Keep in mind in some cases it can be difficult to fully diagnose or help repair your vehicle without seeing it and I work on delivering the best possible answer from what I see to work with.

Thanks Pete