How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Ron Your Own Question
Ron
Ron, ASE Certified Technician
Category: Ford
Satisfied Customers: 23001
Experience:  23 years with Ford specializing in drivability and electrical and AC. Ford certs and ASE Certs
7276279
Type Your Ford Question Here...
Ron is online now
A new question is answered every 9 seconds

I HAVE A 2013 FORD EXPLORER. HAD A NEW BATTERY INSTALLED.

Customer Question

I HAVE A 2013 FORD EXPLORER. HAD A NEW BATTERY INSTALLED. THEN NEEDED A NEW BATTERY TWO MONTHS LATER. THE ELECTICAL SYSTEM CHECKED OUT FINE. I SEE THE TAIL LIGHTS FLASH SOMETIME WHEN THE CAR IS OFF, BUT IT SEEMS THAT SOMETHING IS DRAINING THE BATTERY
Submitted: 1 year ago.
Category: Ford
Expert:  sarmiento22556 replied 1 year ago.

Hello, I will try to help you with your concern.

Yes it does sound like you have a parasitic draw in your vehicle. There are so many possibilities it would be impossible to guess. You will need to take it to a repair shop that you trust to have it thoroughly diagnosed. Be prepared to possibly leave it for a few days so they can make a complete diagnosis. Sometimes the draws will come and go making it very difficult to find.