How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Jeremy Your Own Question
Jeremy
Jeremy, Certified Diesel Technician/Electrician
Category: Ford
Satisfied Customers: 2783
Experience:  ASE, NATEF Engines and Electrical certified, EPA 608/609
9290743
Type Your Ford Question Here...
Jeremy is online now
A new question is answered every 9 seconds

I have a 2014 F-350 I bought as a cab and chassis and had

Customer Question

I have a 2014 F-350 I bought as a cab and chassis and had the dealership install a CM flatbed before I even picked it up. Everything was working great til about 36,000 miles then I had my rear running lights stop working. Soon after I lost my turn signals and everything except for my top right light on the headache rack of the bed. All lights on my cab work perfect and I have the one top right headache rack light still working on the bed but nothing else. Any ideas on what this could be?
Submitted: 11 months ago.
Category: Ford
Expert:  Jeremy replied 11 months ago.

My name is ***** ***** I will assist you.

What functions does the top right light on the cab do?

When you mention lights on the cab work, does the turn signals work or you lost them on the whole vehicle?

Do you know if the body builder used the main light harness for the chassis or if they used the body builder box for the lights?

__________________________________________________________________________________________________________________________
You want a 5 star service and I want to provide a 5 star service. Please consider that I don't know your skill level as well as I can't see,
touch, smell, hear the vehicle/machine in question. Please provide as much detail as possible and I will provide as much back.

Once an answer is provided, you should see a rating screen. Please rate my personal service to you. The ratings are my personal feedback,
they are not the site feedback.

Thank you for allowing me to assist you through Just Answer!

Jeremy

Customer: replied 11 months ago.
The top passengers side light on the headache rack of the flatbed is the only one working. And it only works with the turn signal and the brake. They have a 6 pin ran from the cab to connect to a 6 pin for the flatbed. All signals and lights on the cab itself work perfectly. Just don't have any lights on the flatbed besides the one on the top passengers side headache rack. Is there a fuse or relay that controls driver/passenger rear lights separately? I'm much better with a little older vehicles but not a dummy so I can usually figure out things like this but it's got me a bit stuck since I need to be on the road tomorrow
Customer: replied 11 months ago.
The only lights I have lost are the ones on my flatbed. All except my one up top I've spoke of
Expert:  Jeremy replied 11 months ago.

Sounds like the bed might be running through the trailer circuit.

There are fuses for it. Check for the fuses for the trailer circuit in the owner manual to know which ones they are in teh fuse box. I just tried pulling up the breakdown and the website locked on me. Ford has been having issues with the servers for the last 3 days now.

If the lights are coming off the 6 way plug, they did everything on the trailer. Otherwise they would have done them on the harness at the back of the frame where the harness splits into 3.

Customer: replied 11 months ago.
they would run everything on the trucks bed through the trailer circuit?
Expert:  Jeremy replied 11 months ago.

Yes. A lot of body builders do that to separate the bed from the cab. Not all of them, but the majority. It's because the regular tail lights for a standard pick up bed runs through the lighting module to prevent throwing codes on the truck every time a light burns out.

Pickup beds only have the 2 tail lamps and the reverse lights as well as the plate. The bodies like you have will have clearance lights, work lights added, additional turn and braking for safety, maybe even strobes. When one bulb goes out, you will get a lighting code each time and it can get frustrating on a working truck like that for each time a clearance light gets bumpedfrom loading/unloading as example.

Customer: replied 11 months ago.
Well the truck has been sitting awhile and the last it was used it was from my old crew. One of the lights on the headache rack was pushed in. Think it might just be a bed light issue causing the rest not to get power through the circuit? All the bulbs seemed to look good but should I start by just replacing them all and seeing if one was messed up?
Expert:  Jeremy replied 11 months ago.

I would start with the one that is obvious after checking the fuses to see if that one is causing the rest to go out.

Then I would unplug them or remove the bulbs on them one by one, then check for power going to them on a different ground to rule out grounding due to the one light that you had to push in. Usually on a bed like that, it is something simple like a light grounding out.

Customer: replied 11 months ago.
Changed one light and it made all but the tail lights start working. On my way to get a few more lights to change some on the rear and see if it comes around. Don't have a voltmeter or anything handy so I'll do it the time consuming way. Let you know something soon. Thanks!
Expert:  Jeremy replied 11 months ago.

Lights grounded out.

You're welcome.

Expert:  Jeremy replied 11 months ago.

I see you viewed this and this is still showing as a open question due to no positive (3 stars or more) rating.

Did you still need assistance with this?

Customer: replied 11 months ago.
Lights didn't ground out. Had to leave it at a ford dealer in Ohio so I could leave for Oklahoma yesterday morning. I'm sure we could have figured it out but we ran out of time. The dealership still hasn't figured it out either. I was more than happy with the quick responses and the direction just didn't get it fixed and didn't know I needed to give a rating.
Expert:  Jeremy replied 11 months ago.

Well, that is a bummer that it had to be sent to them. Well, shoot...

I don;t get anything for my time until a rating is made. Otherwise, I did everythign for free. i don;t work for the site. They are a go between like eBay for example. All they do is take the deposits, then pay a small portion after a rating is done to make sure the custoemr is happy. This is also because there could be 5 people that may have helped in a real complex issue and you choose who you got the most help from, questions replied to, etc.

Ratings are for my personal service to you, not the site or how there side is. They send that to you after for comments with them.

Expert:  Jeremy replied 11 months ago.

it's odd that they can't figure it out considering they have the IDS and they can power the circuit from the computer, to the lighting module, and then get a instant spot where to check.

If they drag it out on you, tell them to stop screwing around for pennies and put their better electrician on it and do the job instead of trying to milk you for a wiring job. i know it can be hard to locate, but they have the tools specific for the job paid by the dealership and Ford to locate the issue where sponsored shops like myself and independents like yourself don't always have the access to that equipment.

I'm always in the customer corner when it comes to dealing with them...

Have a safe trip to the corral aka Oklahoma!

Customer: replied 11 months ago.
I will ask them about exactly what you said. We figured they were screwing us around a little. The just ask website charged me the 5 deposit and the $43 after already and it said it would do that after the rating. I'd much rather send the money to you cause it told me it wouldn't charge the $43 unless I was satisfied. Which I am but hell I don't wanna pay $100 for it. But you definitely got 5 stars in my book of that means anything Jeremy
Expert:  Jeremy replied 11 months ago.

I don't do anything with the account charges. I don't work for them. i work through them.

I do know that they charge a deposit and most people get confused when they see a pending on the card statements, but that is the authorization, not the actual charge to my knowledge of asking questions to lawyers and such on here myself. They do run the authorization to make sure the account supports the fee, but there is no charge until the rating is done. Then I don't get anything until a rating is made. No rating is no pay on my end, even if the deposit was made.

if there are any issues at all, on your side of the box, there is a link for customer service. You can click on it and they will assist you and make sure all is correct.

It confuses people on how the whole pre-authorization hit works. It's like renting a car or a hotel room. Same way. If it isn't used, it goes right back like you never used it in a 2 or 3 day wait on the pre-authorize.

Expert:  Jeremy replied 10 months ago.

I see you viewed this and this is still showing as a open question due to no positive (3 stars or more) rating.

Did you still need assistance with this?