How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Ron Your Own Question
Ron
Ron, ASE Certified Technician
Category: Ford
Satisfied Customers: 23001
Experience:  23 years with Ford specializing in drivability and electrical and AC. Ford certs and ASE Certs
7276279
Type Your Ford Question Here...
Ron is online now
A new question is answered every 9 seconds

I have Ford Windstar 2002 which starts acting weird. ABS

Customer Question

Hi Mike, I have Ford Windstar 2002 which starts acting weird. ABS light starts to go on , speedometer sometimes not working, tire presure light is on for while( I check presure and its ok) and transmission light is flashing every time I start the car or standing for a while on traffic lights, once in motion the light goes off. any suggestion?
Submitted: 11 months ago.
Category: Ford
Expert:  Ironmike replied 11 months ago.

is there a way we can check codes? do you have access to an advanced scanner?

Expert:  Ironmike replied 11 months ago.

If there are codes stored in the instrument cluster, abs module or PCM it would help give us direction in the diagnosis process.

Expert:  Ironmike replied 11 months ago.

I use a program on my Samsung s5 with a Bluetooth adapter. both cost less than 30$.

Expert:  Ironmike replied 11 months ago.

there is a bulletin for symptoms like you describe. The PCM gets wet from water leaking on or into it. There is a kit and procedure the dealer is aware of.

Expert:  Ironmike replied 11 months ago.

let me know if you would attempt to do the repair.

Customer: replied 11 months ago.
Unfortunately i don't have any diagnostic tools. I'm more in to mechanical parts than electronic. I have seen on one internet forum that this problems could be caused by malfunction speedo sensor. I know that I have brake sensor located on main break piston leaking (more sweating) on transmission. Do you think that that's can be related?
Expert:  Ironmike replied 11 months ago.

The bulletin I saw fits your symptoms and I have seen it a few times at the dealership. The PCM is at the base of the fire wall on the passenger side. I would check that, especially if it has been rainy or wet by you.

Expert:  Ironmike replied 11 months ago.

under the cowl

Expert:  Ironmike replied 11 months ago.

top of firewall passenger side. cowl has to come off. looking for a picture

Expert:  Ironmike replied 11 months ago.

here

Expert:  Ironmike replied 11 months ago.

really need codes. you could check fuses and grounds and poser supply to the under hood fuse box. lots of things to check without diagnostic direction

Expert:  Ironmike replied 11 months ago.

power supply

Customer: replied 11 months ago.
I will have codes in about 2-3 hours so We can go from there. In mean time I will check if there are marks of water dripping on PCM.
Customer: replied 11 months ago.
looks like the main problem will be the water dripping in PCM. Still waiting for codes
Expert:  Ironmike replied 11 months ago.

yep, you can disconnect the battery. after we get codes and see what the connector to the PCM looks like. You can use a blow dryer to dry out the PCM and see if that helps.

Expert:  Ironmike replied 11 months ago.

tsb

Customer: replied 11 months ago.
here are the codes. I disconnect the battery and check the PCM connector its little bit wet so I dry it up but ABS light is still on and transmission still blinking while the car is on idle.
Expert:  Ironmike replied 11 months ago.

I see codes for the ABS. what about trans and engine codes? these vans are known for water/moisture in the ABS module(EBCM). The abs module and the hydraulic valve body are attached and it is located under the vehicle on the drivers side almost under the drivers seat. There is a plastic cover the hides it. I found a gut off the internet that repairs them for 50$. I removed it and sent it to him(can't use the vehicle with no abs module)

Ford will sell you the module for 700-800$. almost all the time the screws will break that hold the module, I got 2 out. I just used silicone and a plastic tie wrap. No codes, wife is happy.

Expert:  Ironmike replied 11 months ago.

you may have more than one issue.

Expert:  Ironmike replied 11 months ago.

I will see if I can find the guy that did mine

Expert:  Ironmike replied 11 months ago.

found the e-mail, got it from e-bay. I see a few that do the repair. my e-mail just says I paid with paypal from e-bay.

Expert:  Ironmike replied 11 months ago.

here is web site

www.speedometerrepairguy.com

Expert:  Ironmike replied 11 months ago.

I see he went up in price. I still see guys that say they will repair for 50$

Customer: replied 11 months ago.
I just run in to Ford dealer to check some prices for parts and they offered me full car inspection for 90 bucks so i will go for it and see what they will say and go from there. My problem is that this is my only car which I need every day for drive to work.
Customer: replied 11 months ago.
The ABS modules are close to fuel filter ?
Expert:  Ironmike replied 11 months ago.

abs module/HCU are right in front of the fuel filter

Expert:  Ironmike replied 11 months ago.

usually when a module has that many codes it winds up the module is no good.

Customer: replied 11 months ago.
Is there any chance to check the module visually? I just change the fuel filter so I know how to get in that spot.
Customer: replied 11 months ago.
I will run diagnostic today again to get the transmission codes
Expert:  Ironmike replied 11 months ago.

the is a cover over it. you could look to see what it will take to remove the module but you probably will not see any signs of water or moisture. It is inside. They have to cut the plastic case open to clean and re solder for the repair. they glue it closed.

Expert:  Ironmike replied 11 months ago.

the trans codes could be cause by the abs module. The vehicle needs to see wheel speed and uses the abs system.

Customer: replied 11 months ago.
the latest codes (unfortunately the device which I use don't read trans codes). P0171, P0705, P1401, P0174, C1155, C1233, C1185, C1198, C1194, C1254, C1246, C1250, C1242, C1214, C1210.
So it seems to me I have problem with ABS module + speed sensor. Don't know if that can caused the trans codes.
Expert:  Ironmike replied 11 months ago.

P0705 is a trans code. It is a malfunction with the range sensor. the C codes are abs and the P0171,174 lean codes.

Customer: replied 11 months ago.
Oh so that's the reason that my beck up lights are not working. This sensor is on top of the trans next to gear shifter?
Customer: replied 11 months ago.
I have leaking gaskets on head so that's for lean codes. All together I will have to replace head gasket (or live with leaking oil) replace or fix ABS module, replace speed sensor (most likely both front wheel and transmission) and car should be good?
Expert:  Ironmike replied 11 months ago.

Intake gaskets with the isolator bolts are a common leak on these engines. Not head gaskets, intake or they can be called upper plenum gaskets. The range sensor for the trans is mounted on the top of the transmission.

Related Ford Questions