How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Ron Your Own Question
Ron
Ron, ASE Certified Technician
Category: Ford
Satisfied Customers: 23001
Experience:  23 years with Ford specializing in drivability and electrical and AC. Ford certs and ASE Certs
7276279
Type Your Ford Question Here...
Ron is online now
A new question is answered every 9 seconds

Blower motor rear of a 2000 ford expedition is not working

Customer Question

Customer: blower motor for the rear of a 2000 ford expedition is not working at all. i seem to have misplaced the owners manual so i am not sure what fuse is what< however I checked all fuses under the hood and in fuse block below dash on drivers side - all check good. my name is ***** *****
JA: Thanks. Can you give me any more details about your issue?
Customer: I sent what is wrong on first text -
JA: OK got it. Last thing — JustAnswer charges a fee (generally around $28) to post your type of question to Ford Experts (you only pay if satisfied). There are a couple customers ahead of you. Are you willing to wait a bit?
Customer: not blower in rear - motor not working at any speed. lost owners manual so cannot look up fuse locations but had checked them all, another odd thing is not heat to the front but blower works, blend door is working (a/c cold on cool setting but goes to outside temp if turned to hot. sounds like a heater core problem to me (front) unless there is a heater control valve son valve some where - which i cannot find
JA: OK. Now I'm going to take you to a page to place a secure deposit with JustAnswer. Don't worry, this chat is saved. After that, we will finish helping you.
Submitted: 1 year ago.
Category: Ford
Expert:  HDGENE replied 1 year ago.

Hello, Im a little confused to your question. The rear blower motor isnt working and you have poor heat for the rear system?