How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask rpmdiag Your Own Question
rpmdiag
rpmdiag, Tech and Instructor
Category: Ford
Satisfied Customers: 6848
Experience:  Since 1975
12769047
Type Your Ford Question Here...
rpmdiag is online now
A new question is answered every 9 seconds

I have a 1996 f250 5.8 the fuel pump went out and i went to

Customer Question

i have a 1996 f250 5.8 the fuel pump went out and i went to replace it when i found out there was no power going to it i hot wired the pump now i have the pump running and fuel pressure at the engine when i crank the engine but it wont fire but if i spray starting fluid into the air intake i get a very quick engine crank then nothing do you have any clue why its not running
Submitted: 12 months ago.
Category: Ford
Expert:  rpmdiag replied 12 months ago.

Hi, I’m Ron and I can help you.
I have been in this business since 1975 and also teach automotive repair. I am confident we can resolve your problem together. Please understand that I don't know your skill level. I can't see, smell, hear, or touch the vehicle either, so it may take a few replies to get to satisfactory results. Please be patient!
I also try to give all of the information you may need, expecting a “positive rating” in return. I will also continue assisting you after you have rated me, if necessary. If there is any reason I cannot get a positive rating, please let me know why “in advance”, so I can go another direction for you. I am sorry you’re having this problem; I’ll help you through it.

The power to the pump comes via the computer. First check all your wiring, fuses and relays.

Thanks, Ron

Customer: replied 12 months ago.
i have went to just running power to the pump with my own wire the pump is running now and i have pressure at the engine i just cant get the engine to fire up with fuel now getting to it
Expert:  rpmdiag replied 12 months ago.

Hi, I’m Ron and I can help you.
I have been in this business since 1975 and also teach automotive repair. I am confident we can resolve your problem together. Please understand that I don't know your skill level. I can't see, smell, hear, or touch the vehicle either, so it may take a few replies to get to satisfactory results. Please be patient!
I also try to give all of the information you may need, expecting a “positive rating” in return. I will also continue assisting you after you have rated me, if necessary. If there is any reason I cannot get a positive rating, please let me know why “in advance”, so I can go another direction for you. I am sorry you’re having this problem; I’ll help you through it.

I would still check the pressure and volume with a gauge so we can move on to other options such as exhaust restrictions, bad MAF sensor etc. If you have scan tool data, that sure would be helpful at this point and any possible codes that are in the computer.

Thanks, Ron

Customer: replied 12 months ago.
i dont have a scan tool but i do have the pressure gauge... with the pump running i have 50psi this is an old pressure gauge so i cant be for sure thats the right amount of pressure in the line but it does jump up to 50 when the pump is switched on
Expert:  rpmdiag replied 12 months ago.

We need to be accurate in our reading and tools we use, otherwise we're just wasting each other's time.

Thanks, Ron

Related Ford Questions