How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Ron Your Own Question
Ron
Ron, ASE Certified Technician
Category: Ford
Satisfied Customers: 23001
Experience:  23 years with Ford specializing in drivability and electrical and AC. Ford certs and ASE Certs
7276279
Type Your Ford Question Here...
Ron is online now
A new question is answered every 9 seconds

I have a 2001 f250 with a 7.3 in it. it started off with a

Customer Question

I have a 2001 f250 with a 7.3 in it. it started off with a weird idle. it would go from about 500rpm to about a 1000 rpm. I put on a new cam sensor and throttle position sensor which didn't help. In the meantime it developed a miss after it would warm up. I then took it to the dealer where they put on a injector pressure regulator and an under valve cover wire harness. these too didn't help so they put on a fuel injector module that still made no difference. if anything it got worse. so I took it back and now they say it has an exhaust back pressure code in it. they say its puzzling them. I don't have money to just keep putting in parts so just wondering if you had any thoughts.
Submitted: 1 year ago.
Category: Ford
Expert:  James replied 1 year ago.

Hello, if you disconnect the icp sensor is there oil present in the sensor?