How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask jazzmaster Your Own Question
jazzmaster
jazzmaster, ASE Certified Tech
Category: Ford
Satisfied Customers: 2951
Experience:  ase certified--32 yrs experience
8668911
Type Your Ford Question Here...
jazzmaster is online now
A new question is answered every 9 seconds

93 f 250 won't run after running a couple minutes.7.5 v8

Customer Question

93 f 250 won't run after running a couple minutes.7.5 v8
Submitted: 1 year ago.
Category: Ford
Customer: replied 1 year ago.
Forget it. It was the ect sensor. Enjoy the 5 dollars.
Customer: replied 1 year ago.
Lol. Still wontvrun. Any ideas?
Customer: replied 1 year ago.
Pcm pip cap rotor fuel filter all new
Expert:  jazzmaster replied 1 year ago.

hi, did you check to see if it has spark?

or does it still start and then stall ?

Customer: replied 1 year ago.
Has spark has fuel
Customer: replied 1 year ago.
New ect New pip tried New ignition module no dice. After about 2 minutes dies won't restart till cold. Pcm also swapped out.
Expert:  jazzmaster replied 1 year ago.

so, you replaced the dist pick up assembly ?

when it doesn't start it has fuel and spark?

will it start and stall if you spray carb cleaner into the throttle body ?

have you checked for injector pulse when it wont start ?

does it have good fuel pressure ?

Customer: replied 1 year ago.
Fuel press good. Spark good . Pops off but does not run with starting fluid
Customer: replied 1 year ago.
Injectors pulse
Expert:  jazzmaster replied 1 year ago.

what does the fuel pressure read at ?

Expert:  jazzmaster replied 1 year ago.

when this starts does it run good ?

Customer: replied 1 year ago.
40 psi runs ok when it runs
Expert:  jazzmaster replied 1 year ago.

did you replace the dist pick up assembly ?

Customer: replied 1 year ago.
Customer did yes
Expert:  jazzmaster replied 1 year ago.

so the fuel pressure looks ok, is the spark bright and the injector pulse bright ?

Customer: replied 1 year ago.
Expert:  jazzmaster replied 1 year ago.

if you disconnect the pip/spout connector will it start then ?

Customer: replied 1 year ago.
At the distributor? I do not believe so. I can try in the am.
Expert:  jazzmaster replied 1 year ago.

so, this came to you after the customer replaced all those parts and couldn't figure it out ?

Customer: replied 1 year ago.
indeed
Expert:  jazzmaster replied 1 year ago.

did he/she tell you why the parts were replaced ,"? what I mean is the issue the same thing before the parts were replaced ?

Customer: replied 1 year ago.
runs then stalls till cold again
Expert:  jazzmaster replied 1 year ago.

have you checked at the fuel and ecc/power relays for corrosion or a bad connection ?

Expert:  jazzmaster replied 1 year ago.

Hi, I am just checking back .

If I helped please rate me positive and we can still continue if needed .

this is the only way I receive credit for the question ..thank you ...jazzmaster ...