How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Ron Your Own Question
Ron
Ron, ASE Certified Technician
Category: Ford
Satisfied Customers: 23001
Experience:  23 years with Ford specializing in drivability and electrical and AC. Ford certs and ASE Certs
7276279
Type Your Ford Question Here...
Ron is online now
A new question is answered every 9 seconds

I have a 99 E450 7.3, my engine cranks but will not fire

Customer Question

I have a 99 E450 7.3, my engine cranks but will not fire when cold or has been sitting a while, if I put some starter fluid in the air breather the engine will fire immediately and keep running with no further problems while driving. The engine will start when warm, but if let sit for an hour or more I will need to use the starter fluid again. What part is dying or needed?
Submitted: 1 year ago.
Category: Ford
Expert:  Ray M. replied 1 year ago.

From experience it is most likely the glow plug relay, locate and replace it and your problems should be fixed.

Customer: replied 1 year ago.
Where is it usually? Expensive part?
Expert:  Ray M. replied 1 year ago.

On the E series it is under the enginecover and mounted on the rear of the drivers side valve cover. I believe they run about $100.

Customer: replied 1 year ago.
Thanks so much!!!
Expert:  Ray M. replied 1 year ago.

You are very welcome, thank you for using JustAnswer.

Customer: replied 1 year ago.
its just to the left of the fuel filter.....
Customer: replied 1 year ago.
Did not fix, put new relay and then tried the ICP, neither fixed it.....are we down to the IPR?
Expert:  Ray M. replied 1 year ago.

There should be two there, one is for the glowplugs and the other is for the air intake heater. You have to make sure you replaced the correct one. You said it will start and run with using starter fluid so the high pressure oil system is working properly, if the IPR were stuck or inoperative it wouldn't keep running.

Customer: replied 1 year ago.
There was only one next to the filter, there was not one on the back of the engine as you suggested. Just wondering what else I can try?
Expert:  Ray M. replied 1 year ago.

Is this a US built econoline?

Customer: replied 1 year ago.
no idea where it was made.....are you asking Canada? Im in the US.....
Expert:  Ray M. replied 1 year ago.

The US models had a glow plug controller, this is a aluminum box type moduel on the drivers valve cover with two large connectors in it, one should be black and one should be green

Related Ford Questions