How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Ron Your Own Question
Ron
Ron, ASE Certified Technician
Category: Ford
Satisfied Customers: 23001
Experience:  23 years with Ford specializing in drivability and electrical and AC. Ford certs and ASE Certs
7276279
Type Your Ford Question Here...
Ron is online now
A new question is answered every 9 seconds

I am new to this forum and I am looking forward to having

Customer Question

I am new to this forum and I am looking forward to having the help of this community. Two months ago I purchased a 2012 F-250 with 102,000 miles. Two weeks ago I noticed a coolant leak on the drivers side of the radiator. I did some research and found this is a common issue. I ordered an all aluminum primary radiator replacement. I disassembled the truck and pulled the primary radiator. All seemed well as I was having my dad help me. We installed the new radiator and everything, or so we thought. While I was re-installing the grill support bracket I noticed a sensor not being plugged in. It runs near the primary radiator drivers side. I asked my father where he unplugged it from and he thinks he unplugged it from the somewhere on the bumber, but I have not been able to find a sensor at this location on the internet. It is ziptied a hose and it seems it goes somewhere close to where it is laying. It looks like some kind of temperature sensor, but I am not sure. I thought it was the ambient air temperature, but I have found these are located in the mirrors of these trucks. I have been unable to find this sensor on the internet. Also there is something to note, this truck has the wire components for a fleet vehicle system, so I am not sure if this sensor goes to that. I have attempted to trace the wire, but I only get so far, to the firewall.
Log story short, what is this sensor and where does it plug in? Posting links to pics.
http://i.imgur.com/qbDcWhD.jpg
http://i.imgur.com/iM8VGIu.jpg
http://i.imgur.com/7Nt99Rm.jpg
http://i.imgur.com/yoGyY8p.jpg
http://i.imgur.com/SCHjL3o.jpg
http://i.imgur.com/ixwG0e0.jpg
Submitted: 1 year ago.
Category: Ford
Expert:  HDGENE replied 1 year ago.

Hello, not a great picture of the connector, how many wires does it have and what color are the wires?