How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask jazzmaster Your Own Question
jazzmaster
jazzmaster, ASE Certified Tech
Category: Ford
Satisfied Customers: 2951
Experience:  ase certified--32 yrs experience
8668911
Type Your Ford Question Here...
jazzmaster is online now
A new question is answered every 9 seconds

Ranger pickup would fail to restart after 15 mile drive.

Customer Question

ranger pickup would fail to restart after***** After about 10 minutes it would start. Installed new ignition relay now it wont start at all even with old relay. V6 manual
Submitted: 1 year ago.
Category: Ford
Expert:  jazzmaster replied 1 year ago.

hi, when you say it won't start does the motor turn over but it wont run or the motor wont turn over ?

also, the relay you replaced is that the starter relay ?

Customer: replied 1 year ago.
no not the starter relay, the ignition relay - motor turns over fine, no spark from coil
Expert:  jazzmaster replied 1 year ago.

ok, you are talking about the ecc power relay ,the one that has a yelllow a red wire a red/lt green wire and a black/lt green wire to it ?

do you hear the fuel pump come on for 2-3 seconds when you first turn the key to the run position (not cranking ?

Expert:  jazzmaster replied 1 year ago.

DO YOU HAVE bat voltage on the yellow wire at all times and on the red/lt green when you turn the key on ?

also on the red wire when you turn the key on ?

Customer: replied 1 year ago.
will check tomorrow and let you know
thanks
Expert:  jazzmaster replied 1 year ago.

ok, also if you can check to see if you have bat voltage at the red wires at the fuel injectors ,you dont really have to check all of them ,but some ,,thanks ...jazzmaster ..

Customer: replied 1 year ago.
ok, I don,t have a fuel problem just no spark
Expert:  jazzmaster replied 1 year ago.

yes, but I need to know if there is voltage to help you better .

also, check to make sure the dist rotor is turning when you crank the motor .and the ignition module should be taken off and checked at an auto parts store ..thanks ..

Customer: replied 1 year ago.
ok
Expert:  jazzmaster replied 1 year ago.

good morning

Customer: replied 1 year ago.
Distributor rotor is turning. Ignition module, dist cap and rotor are new, Truck has been driven since installed.
With ignition sw on I have voltage to red wire and yellow wire at relay. No voltage on red/green wire or the 4th wire
which appears to be beige/white
Customer: replied 1 year ago.
Distributor rotor is turning. Ignition module, dist cap and rotor are new. Truck has been driven since installed.
With ignition sw on I have voltage to red wire and yellow wire at relay. No voltage on red/green wire or the 4th wire
which appears to be beige/white. Voltage to injectors
Expert:  jazzmaster replied 1 year ago.

the red/gr wire should have voltage when cranking ,that other wire should show a ground

my wiring diagram may be showing something different as far as a few wires colors .

also, see at the coil if there is voltage on the wires with the key on ..

Customer: replied 1 year ago.
Truck is outside. Raining today and tomorrow. will check asap. Thanks
Customer: replied 1 year ago.
Voltage at coil with key on
Expert:  jazzmaster replied 1 year ago.

and you do hear the fuel pump come on ?

Customer: replied 1 year ago.
no but I never have
Customer: replied 1 year ago.
even if fuel pump does not come on, I should have spark from coil. dist also has new pickup unit
Expert:  jazzmaster replied 1 year ago.

ok, the reason I was asking about the fuel pump coming on and I do know you have no spark is I am trying to cover all bases to better help you .

that red/lt green wire also, supplies voltage to the eec relay and you said you have power to the coil, and do you have power on both sides of the coil.

I am esp. looking at the red/green wire at the coil.

,so there may be a break in the wire after the coil and going to the eec relay .

do you have power on that at the relay when you crank the motor over .

this could be also an issue with the dist pick up coil ,in the dist as well .

Customer: replied 1 year ago.
thanks, ***** ***** make more checks tomorrow
Expert:  jazzmaster replied 1 year ago.

cool, thank you

Expert:  jazzmaster replied 1 year ago.

if you still need help -please let me know.If I helped you please rate me positive and if need be can continue on ,,thank you ...jazzmaster